~ubuntu-branches/debian/sid/cheese/sid

« back to all changes in this revision

Viewing changes to debian/patches/using-fmod-link-libm.patch

  • Committer: Package Import Robot
  • Author(s): Laurent Bigonville
  • Date: 2014-10-19 20:42:33 UTC
  • mfrom: (1.6.9)
  • Revision ID: package-import@ubuntu.com-20141019204233-crj6dccep3y7mxd8
Tags: 3.14.1-1
* New upstream release.
  - Drop debian/patches/using-fmod-link-libm.patch: Applied upstream
* Drop debian/patches/revert-appstream-usage.patch and build-depend against
  appstream-util
* debian/control.in: Bump Standards-Version to 3.9.6 (no further changes)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Andreas Henriksson <andreas@fatal.se>
2
 
Subject: Use LT_LIB_M to find the math library
3
 
 
4
 
libcheese-gtk (sometimes?) needs to link with -lm
5
 
to find the fmod function.
6
 
 
7
 
--- a/Makefile.am
8
 
+++ b/Makefile.am
9
 
@@ -87,6 +87,7 @@
10
 
 
11
 
 libcheese_gtk_la_LIBADD = \
12
 
        libcheese.la \
13
 
+       $(LIBM) \
14
 
        $(CHEESE_LIBS) \
15
 
        $(CHEESE_GTK_LIBS)
16
 
 
17
 
--- a/configure.ac
18
 
+++ b/configure.ac
19
 
@@ -24,6 +24,9 @@
20
 
 LT_PREREQ([2.2])
21
 
 LT_INIT([disable-static])
22
 
 
23
 
+# Find an appropriate libm, for fmod()
24
 
+LT_LIB_M
25
 
+
26
 
 PKG_PROG_PKG_CONFIG([0.24])
27
 
 
28
 
 AC_SUBST([CHEESE_WFLAGS], ["-Wall -DGSEAL_ENABLE"])