~ubuntu-branches/debian/sid/dico/sid

« back to all changes in this revision

Viewing changes to debian/patches/dicoweb-django.diff

  • Committer: Package Import Robot
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2012-06-29 11:03:01 UTC
  • Revision ID: package-import@ubuntu.com-20120629110301-8wh8cbbcw0uvmynh
Tags: 2.2-2
* debian/rules: Enable all hardening flags.
* Added dicoweb-django.diff patch to replace deprecated load_template_source
  callers. (Closes: #678912)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: django.template.loaders.*.load_template_source is deprecated in 
 
2
  Django 1.4
 
3
Forwarded: no
 
4
Bug-Debian: http://bugs.debian.org/678912
 
5
Author: أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@sabily.org>
 
6
--- a/dicoweb/settings-sample.py
 
7
+++ b/dicoweb/settings-sample.py
 
8
@@ -61,8 +61,8 @@
 
9
 
 
10
 # List of callables that know how to import templates from various sources.
 
11
 TEMPLATE_LOADERS = (
 
12
-    'django.template.loaders.filesystem.load_template_source',
 
13
-    'django.template.loaders.app_directories.load_template_source',
 
14
+    'django.template.loaders.filesystem.Loader',
 
15
+    'django.template.loaders.app_directories.Loader',
 
16
 )
 
17
 
 
18
 MIDDLEWARE_CLASSES = (