~ubuntu-branches/debian/sid/gnat-4.4/sid

« back to all changes in this revision

Viewing changes to debian/patches/gcc-unwind-debug-hook.diff

  • Committer: Bazaar Package Importer
  • Author(s): Ludovic Brenta
  • Date: 2010-05-09 23:28:13 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20100509232813-bykj33gg0mc34opr
Tags: 4.4.4-2
* debian/control.m4, debian/control: make upgrades from Lenny work without
  broken packages or hard decisions.
  (gnat-4.4): replace all previous versions of gnat-X.Y.
  (libgnat{vsn,prj}4.4-dev):
  - Replace the corresponding 4.3 package in addition to Conflicting with it.
  - Suggest the -dbg package, too.
  (libgnat{vsn,prj}4.4-dbg):
  - Depend on the -dev package, too.
  - Do not recommend gnat-gdb, superseded by gdb.
  (libgnatprj4.4-dbg): do not recommend libgnatprj-dev, no longer in the archive.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
# DP: a hook for a debugger to intercept exceptions. CFA is the CFA of the
3
3
# DP: target frame.  HANDLER is the PC to which control will be transferred.
4
4
 
 
5
2010-04-27  Jakub Jelinek  <jakub@redhat.com>
 
6
 
 
7
        * unwind-dw2.c (_Unwind_DebugHook): Add used attribute.
 
8
 
5
9
2009-05-27  Tom Tromey  <tromey@redhat.com>
6
10
 
7
11
        * unwind-dw2.c (_Unwind_DebugHook): New function.
9
13
 
10
14
--- a/src/gcc/unwind-dw2.c      (revision 147933)
11
15
+++ b/src/gcc/unwind-dw2.c      (revision 147934)
12
 
@@ -1473,18 +1473,31 @@ uw_init_context_1 (struct _Unwind_Contex
 
16
@@ -1473,18 +1473,32 @@ uw_init_context_1 (struct _Unwind_Contex
13
17
   context->ra = __builtin_extract_return_addr (outer_ra);
14
18
 }
15
19
 
16
 
+static void _Unwind_DebugHook (void *, void *) __attribute__ ((__noinline__));
 
20
+static void _Unwind_DebugHook (void *, void *)
 
21
+  __attribute__ ((__noinline__, __used__));
17
22
+
18
23
+/* This function is called during unwinding.  It is intended as a hook
19
24
+   for a debugger to intercept exceptions.  CFA is the CFA of the