~ubuntu-branches/debian/sid/libembperl-perl/sid

« back to all changes in this revision

Viewing changes to debian/patches/delay.patch

  • Committer: Bazaar Package Importer
  • Author(s): Gunnar Wolf, Jonathan Yu, Damyan Ivanov, Ryan Niebur, gregor herrmann, Gunnar Wolf
  • Date: 2009-10-15 11:43:24 UTC
  • mfrom: (1.2.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20091015114324-2rnqzsj9jmpwd9nt
Tags: 2.3.0-1
[ Jonathan Yu ]
* New upstream release
  + SSI syntax now behaves more like mod_include
  + Improved XHTML/XML support
  + Fix to correctly retrieve Cookie header under apache2
  + Fix segfault when a value of an input attribute is removed
* Bringing this package under the pkg-perl group (Closes: #543609)
* Updated d/watch with CPAN search site
* Standards-Version 3.8.3
  + Remove version dependency on perl
  + Add Vcs-* and Homepage fields
* Drop version dependency on:
  + apache2-prefork-dev (>= 2.2.3-3.3) [oldstable 2.2.3-4]
  + apache2-mpm-prefork (>= 2.2.3-3.3) [oldstable  2.2.3-4]
  + libapache2-mod-perl2 (>= 2.0.2-2.3) [oldstable 2.0.2-2.4]
* Remove libcgi-pm-perl | perl-modules (>= 5.8.0) | libcgi-perl,
  which is always satisfied by perl
* Add extensive patches to fix POD errors and add whatis entries
* Add a patch to remove some Unicode data from POD; it was causing
  an obscure error with `AE' (thanks Ryan52!)

[ Damyan Ivanov ]
* debian/rules: fix target dependencies

[ Ryan Niebur ]
* Update jawnsy's email address
* Update ryan52's email address

[ gregor herrmann ]
* Split out all changes to upstream code into proper patches managed by
  quilt.
* Add patch cgi_pm.patch by Niko Tyni to avoid FTBFS if a newer CGI.pm is
  present at test time (closes: #521971).
* Update debian/copyright.
* debian/rules:
  - clean up a bit
  - call make with "-j1", the upstream build system is not parallel-build safe
  - add support for DEB_BUILD_OPTIONS nocheck
* Change Section to "perl".
* Remove dbinitembperlapache (created by test suite).

[ Gunnar Wolf ]
* Updated README.Debian to reflect the current reality re: thread
  safety, dropping mentions of obsolete mod_perl v1 and mentioning the
  deprecation of embperl itself
* Reload Apache if a2enmod/a2dismod was called in postinst/prerm
* Added Suggests: apache2-mpm-prefork, as it is the closer we can get to
  get the non-threaded versions of Apache2 by default besides
  documenting, which is already done in README.Debian. (Closes: #412521)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Add additional delay loop to test.pl, for ridiculously slow machines
 
2
 (like heavily loaded m68k/arm buildds)
 
3
Author: Angus Lees <gus@debian.org>
 
4
 
 
5
--- a/test.pl
 
6
+++ b/test.pl
 
7
@@ -2685,6 +2685,7 @@
 
8
            }
 
9
 
 
10
         my $tries = ($opt_gdb || $opt_ddd)?30:15 ;
 
11
+       my $delay = 1 ;
 
12
         $httpdpid = 0 ;
 
13
         my $herr = 0 ;
 
14
 
 
15
@@ -2708,7 +2709,7 @@
 
16
                     }
 
17
                 }
 
18
 
 
19
-            sleep (1) ;
 
20
+            sleep ($delay++) ;
 
21
             }
 
22
         close HERR if ($herr) ;
 
23
 
 
24
@@ -2717,6 +2718,19 @@
 
25
 
 
26
         print "pid = $httpdpid  ok\n" ;
 
27
 
 
28
+       # additional delay step for really slow machines (m68k/arm)
 
29
+       $tries = 0 ;
 
30
+       while ($tries++ < 8)
 
31
+         {
 
32
+           use IO::Socket::INET;
 
33
+           my $sock = new IO::Socket::INET
 
34
+             PeerAddr => $host,
 
35
+             PeerPort => $port,
 
36
+             Timeout => 10;
 
37
+           last if $sock;      # connected successfully
 
38
+           sleep(1.5**$tries);
 
39
+         }
 
40
+
 
41
        close ERR ;
 
42
        if (!open (ERR, "$httpderr"))
 
43
             {