~ubuntu-branches/debian/sid/libembperl-perl/sid

« back to all changes in this revision

Viewing changes to debian/patches/perl5.12.patch

  • Committer: Package Import Robot
  • Author(s): Florian Schlichting, Jonathan Yu, Salvatore Bonaccorso, Dominic Hargreaves, Ansgar Burchardt, Florian Schlichting
  • Date: 2012-10-02 22:39:09 UTC
  • mfrom: (1.2.5)
  • Revision ID: package-import@ubuntu.com-20121002223909-vhrio164s2xa8qd3
Tags: 2.5.0~rc2-1
[ Jonathan Yu ]
* Imported Upstream version 2.4.0.

[ Salvatore Bonaccorso ]
* debian/copyright: Re-add Ryan and Gregor to copyright for debian/*
  packaging.

[ Dominic Hargreaves ]
* Switch to dpkg-source 3.0 (quilt) format.
* Remove obsolete perl5.10.patch, perl5.12.patch.

[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.

[ Florian Schlichting ]
* Imported Upstream version 2.5.0~rc2 (Closes: #624578, #666011).
* Patches forwarded upstream and thus obsoleted:
  german.patch, new_process_group.patch, utf8.patch, fix-pod-errors.patch,
  fix-whatis.patch, fix-string-typo.patch, fix-pod-unescaped-unicode.patch.
* Refreshed delay.patch (fuzz).
* Dropped modperl.patch, mod_perl versions < 2 are history.
* Dropped Makefile.PL.patch, divide et impera - style:
  + FORCEMP1 is no longer relevant, Makefile.PL can find Apache headers etc
    itself
  + replacing a custom prompt implementation is unnecessary
  + strip .pl suffix in debian/rules instead of Makefile.PL
  + with hardening flags enabled, there is nothing left in the output of
    `apxs2 -q CFLAGS` that makes a difference
* Bumped Standards-Version to 3.9.4 (using copyright-format 1.0) and updated
  upstream copyright holders.
* Switched dh compatibility to level 9 to enable passing of hardening flags.
* Switched to short-form debian/rules.
* Deleted obsolete README.source.
* Removed version on mod-perl dependency (no older version in the archive).
* Moved apache2-mpm-prefork from Suggests: to Recommends:.
* Updated short and long description.
* Replaced embedded code copy (prototype.js) by a symlink and suggest:
  libjs-prototype.
* Added myself to uploaders and copyright.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: epeval.c
2
 
===================================================================
3
 
--- a/epeval.c  (revision 960449)
4
 
+++ b/epeval.c  (revision 960450)
5
 
@@ -350,12 +350,12 @@
6
 
        sRef = "; \\&" ;
7
 
     
8
 
     if (r -> Component.bStrict)
9
 
-        if (flags & G_ARRAY)
10
 
+        if ((flags & G_ARRAY) != G_SCALAR)
11
 
             pSVCmd = newSVpvf(sFormatStrictArray, r -> Component.sEvalPackage, sName, r -> Component.nSourceline, r -> Component.sSourcefile, sArg, sRef, sName) ;
12
 
         else
13
 
             pSVCmd = newSVpvf(sFormatStrict, r -> Component.sEvalPackage, sName, r -> Component.nSourceline, r -> Component.sSourcefile, sArg, sRef, sName) ;
14
 
     else
15
 
-        if (flags & G_ARRAY)
16
 
+        if ((flags & G_ARRAY) != G_SCALAR)
17
 
             pSVCmd = newSVpvf(sFormatArray, r -> Component.sEvalPackage, sName, r -> Component.nSourceline, r -> Component.sSourcefile, sArg, sRef, sName) ;
18
 
         else
19
 
             pSVCmd = newSVpvf(sFormat, r -> Component.sEvalPackage, sName, r -> Component.nSourceline, r -> Component.sSourcefile, sArg, sRef, sName) ;
20
 
@@ -624,7 +624,7 @@
21
 
     if (ppSV && *ppSV)
22
 
         SvREFCNT_dec (*ppSV) ;
23
 
 
24
 
-    if (rc == ok && pSub != NULL && SvTYPE (pSub) == SVt_RV)
25
 
+    if (rc == ok && pSub != NULL && SvROK (pSub))
26
 
         {
27
 
         /*sv_setsv (*ppSV, pSub) ;*/
28
 
         *ppSV = SvRV(pSub) ;
29
 
Index: epcache.c
30
 
===================================================================
31
 
--- a/epcache.c (revision 960449)
32
 
+++ b/epcache.c (revision 960450)
33
 
@@ -265,7 +265,7 @@
34
 
 
35
 
     /* lprintf (r -> pApp, "XXXXX Cache_New [%d/%d] pProviders=%x %s  pCacheItems=%x %s  pCachesToRelease=%x %s\n", _getpid(), GetCurrentThreadId(), pProviders, IsBadReadPtr (pProviders,4 )?"bad":"ok", pCacheItems, IsBadReadPtr (pCacheItems, 4)?"bad":"ok", pCachesToRelease, IsBadReadPtr (pCachesToRelease, 4)?"bad":"ok") ; */
36
 
 
37
 
-    if (SvTYPE(pParam) == SVt_RV)
38
 
+    if (SvROK(pParam))
39
 
         pParam = SvRV (pParam) ;
40
 
 
41
 
     if (SvTYPE(pParam) == SVt_PV)
42
 
@@ -435,7 +435,7 @@
43
 
         }
44
 
 
45
 
     
46
 
-    if (SvTYPE(pParam) == SVt_RV)
47
 
+    if (SvROK(pParam))
48
 
         pParam = SvRV (pParam) ;
49
 
 
50
 
     if (SvTYPE(pParam) == SVt_PV)
51
 
Index: epcmd2.c
52
 
===================================================================
53
 
--- a/epcmd2.c  (revision 960449)
54
 
+++ b/epcmd2.c  (revision 960450)
55
 
@@ -426,7 +426,7 @@
56
 
     HV *   pHV ;    
57
 
     tDomTree * pDomTree = DomTree_self(xDomTree) ;
58
 
 
59
 
-    if (SvTYPE(sText) == SVt_RV && SvTYPE((pAV = (AV *)SvRV(sText))) == SVt_PVAV)
60
 
+    if (SvROK(sText) && SvTYPE((pAV = (AV *)SvRV(sText))) == SVt_PVAV)
61
 
        { /* Array reference inside URL */
62
 
        SV ** ppSV ;
63
 
        int i ;
64
 
@@ -453,7 +453,7 @@
65
 
     
66
 
        }
67
 
 
68
 
-    else if (SvTYPE(sText) == SVt_RV && SvTYPE((pHV = (HV *)SvRV(sText))) == SVt_PVHV)
69
 
+    else if (SvROK(sText) && SvTYPE((pHV = (HV *)SvRV(sText))) == SVt_PVHV)
70
 
        { /* Hash reference inside URL */
71
 
         HE *       pEntry ;
72
 
         char *     pKey ;
73
 
Index: epcomp.c
74
 
===================================================================
75
 
--- a/epcomp.c  (revision 960449)
76
 
+++ b/epcomp.c  (revision 960450)
77
 
@@ -143,7 +143,7 @@
78
 
 
79
 
     ppSV = hv_fetch(pHash, "perlcode", 8, 0) ;  
80
 
     if (ppSV != NULL && *ppSV != NULL && 
81
 
-        SvTYPE(*ppSV) == SVt_RV && SvTYPE((pAV = (AV *)SvRV(*ppSV))) == SVt_PVAV)
82
 
+        SvROK(*ppSV)  && SvTYPE((pAV = (AV *)SvRV(*ppSV))) == SVt_PVAV)
83
 
        { /* Array reference  */
84
 
        int f = AvFILL(pAV) + 1 ;
85
 
         int i ;
86
 
@@ -176,7 +176,7 @@
87
 
 
88
 
     ppSV = hv_fetch(pHash, "compiletimeperlcode", 19, 0) ;  
89
 
     if (ppSV != NULL && *ppSV != NULL && 
90
 
-        SvTYPE(*ppSV) == SVt_RV && SvTYPE((pAV = (AV *)SvRV(*ppSV))) == SVt_PVAV)
91
 
+        SvROK(*ppSV) && SvTYPE((pAV = (AV *)SvRV(*ppSV))) == SVt_PVAV)
92
 
        { /* Array reference  */
93
 
        int f = AvFILL(pAV) + 1 ;
94
 
         int i ;
95
 
@@ -420,7 +420,7 @@
96
 
     if (ppSV == NULL)
97
 
         return  ;
98
 
 
99
 
-    if (*ppSV == NULL || SvTYPE (*ppSV) != SVt_RV)
100
 
+    if (*ppSV == NULL || !SvROK (*ppSV))
101
 
        {
102
 
        if (*ppSV)
103
 
            SvREFCNT_dec (*ppSV) ;
104
 
@@ -456,7 +456,7 @@
105
 
     SV *    pSV ;
106
 
 
107
 
     ppSV = hv_fetch((HV *)(pDomTree -> pSV), (char *)sStackName, strlen (sStackName), 0) ;  
108
 
-    if (ppSV == NULL || *ppSV == NULL || SvTYPE (*ppSV) != SVt_RV)
109
 
+    if (ppSV == NULL || *ppSV == NULL || !SvROK (*ppSV))
110
 
         return  ;
111
 
 
112
 
     pSV = av_pop ((AV *)SvRV (*ppSV)) ;
113
 
@@ -486,7 +486,7 @@
114
 
     char *  s ;
115
 
 
116
 
     ppSV = hv_fetch((HV *)(pDomTree -> pSV), (char *)sStackName, strlen (sStackName), 0) ;  
117
 
-    if (ppSV == NULL || *ppSV == NULL || SvTYPE (*ppSV) != SVt_RV)
118
 
+    if (ppSV == NULL || *ppSV == NULL || !SvROK (*ppSV))
119
 
         {
120
 
         strcpy (r -> errdat1, "CompileMatchStack") ;
121
 
         strncat (r -> errdat1, (char *)sStackName, sizeof (r -> errdat1) - 20) ;
122
 
@@ -541,7 +541,7 @@
123
 
 
124
 
 
125
 
     ppSV = hv_fetch((HV *)(pDomTree -> pSV), (char *)p, e - p, 0) ;  
126
 
-    if (ppSV == NULL || *ppSV == NULL || SvTYPE (*ppSV) != SVt_RV)
127
 
+    if (ppSV == NULL || *ppSV == NULL || !SvROK (*ppSV))
128
 
         return  op == '!'?1:0 ;
129
 
 
130
 
     pAV = (AV *)SvRV (*ppSV) ;
131
 
Index: epcmd.c
132
 
===================================================================
133
 
--- a/epcmd.c   (revision 960449)
134
 
+++ b/epcmd.c   (revision 960450)
135
 
@@ -637,7 +637,7 @@
136
 
            if (pRV == NULL)
137
 
                 return rcMissingArgs ;
138
 
 
139
 
-            if (SvTYPE (pRV) != SVt_RV)
140
 
+            if (!SvROK (pRV))
141
 
                 {
142
 
                 SvREFCNT_dec (pRV) ;
143
 
                 return rcNotAnArray ;