~ubuntu-branches/debian/sid/libsml/sid

« back to all changes in this revision

Viewing changes to debian/patches/0001-honor-buildflags.patch

  • Committer: Package Import Robot
  • Author(s): Andreas Moog
  • Date: 2017-06-08 20:17:01 UTC
  • Revision ID: package-import@ubuntu.com-20170608201701-n1skasprdy4mdvf7
Tags: 0.1.1+git20170608-1
Initial release. (Closes: #864314)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Change Makefile to honor LDFLAGS
 
2
Author: Andreas Moog <andreas.moog@warperbbs.de>
 
3
Origin: other
 
4
Last-Update: 2017-06-13
 
5
 
 
6
Index: libsml/sml/Makefile
 
7
===================================================================
 
8
--- libsml.orig/sml/Makefile
 
9
+++ libsml/sml/Makefile
 
10
@@ -12,6 +12,8 @@ NAME=libsml
 
11
 SOVERSION=1
 
12
 SONAME=$(NAME).so.$(SOVERSION)
 
13
 
 
14
+LDFLAGS += -Wl,-soname=$(SONAME) -shared
 
15
+
 
16
 LIB_DIR=./lib
 
17
 OBJ_LIB=$(LIB_DIR)/$(NAME).o
 
18
 DYN_LIB=$(LIB_DIR)/$(SONAME)
 
19
@@ -54,7 +56,7 @@ libsml: $(ST_LIB) $(OBJ_LIB)
 
20
 endif
 
21
 
 
22
 $(DYN_LIB): $(OBJS)
 
23
-       $(LD) $(LIBS) -shared -soname $(SONAME) -o $@ $^
 
24
+       $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
 
25
 
 
26
 $(OBJ_LIB): $(OBJS)
 
27
        $(LD) -r -o $@ $^