~ubuntu-branches/debian/sid/nautilus-dropbox/sid

« back to all changes in this revision

Viewing changes to debian/patches/fix-path-of-desktop-file.patch

  • Committer: Package Import Robot
  • Author(s): Raphaël Hertzog
  • Date: 2011-11-22 11:04:25 UTC
  • mfrom: (1.1.4)
  • Revision ID: package-import@ubuntu.com-20111122110425-ladrimzb1afydgzd
Tags: 0.7.1-1
* New upstream release.
* Do not touch /var/lib/update-notifier/dpkg-run-stamp as
  /etc/apt/apt.conf.d/99update-notifier does it for us anyway at the end of
  the APT run. Manual installations of the package will not get the
  message but that's ok.
* Drop /var/lib/update-notifier/user.d/dropbox-{re,}start-required
  on removal since we create them in the postinst and they
  might still be there if update-notifier is not installed.
  Closes: #648215
* Drop fix-path-of-desktop-file.patch, applied upstream.
* Refresh all other patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Don't hardcode the path of the desktop file
2
 
 The path of the desktop file depends on the prefix chosen
3
 
 at installation time. Instead of hardcoding it, we substitute
4
 
 it during build.
5
 
Author: Raphaël Hertzog <hertzog@debian.org>
6
 
Origin: vendor
7
 
 
8
 
--- a/dropbox.in
9
 
+++ b/dropbox.in
10
 
@@ -1252,7 +1252,7 @@ def reroll_autostart(should_autostart):
11
 
     if u".config" in contents:
12
 
         autostart_dir = os.path.join(home_dir, u".config", u"autostart")
13
 
         autostart_link = os.path.join(autostart_dir, u"%s.desktop" % "dropbox") #BUILD_KEY.lower()
14
 
-        desktop_file = u"/usr/local/share/applications/%s.desktop" % "dropbox" #BUILD_KEY.lower()
15
 
+        desktop_file = u"@DESKTOP_FILE_DIR@/%s.desktop" % "dropbox" #BUILD_KEY.lower()
16
 
         if should_autostart:
17
 
             if os.path.exists(desktop_file):
18
 
                 if not os.path.exists(autostart_dir):
19
 
--- a/Makefile.am
20
 
+++ b/Makefile.am
21
 
@@ -6,11 +6,11 @@ EXTRA_DIST = dropbox.in serializeimages.
22
 
 man_MANS = dropbox.1
23
 
 
24
 
 dropbox: dropbox.in serializeimages.py
25
 
-       python serializeimages.py $(PACKAGE_VERSION) < dropbox.in > dropbox
26
 
+       python serializeimages.py $(PACKAGE_VERSION) $(datadir)/applications < dropbox.in > dropbox
27
 
        chmod +x dropbox
28
 
 
29
 
 dropbox.1: dropbox.txt.in dropbox docgen.py
30
 
        python docgen.py $(PACKAGE_VERSION) < dropbox.txt.in > dropbox.txt
31
 
        $(RST2MAN) dropbox.txt > dropbox.1
32
 
 
33
 
-SUBDIRS = data src
34
 
\ No newline at end of file
35
 
+SUBDIRS = data src
36
 
--- a/serializeimages.py
37
 
+++ b/serializeimages.py
38
 
@@ -10,5 +10,6 @@ sys.stdout.write(sys.stdin.read().replac
39
 
                      ('@IMAGEDATA16@', "gtk.gdk.pixbuf_new_from_data(%r, gtk.gdk.COLORSPACE_RGB, %r, %r, %r, %r, %r)" % \
40
 
                           (pixbuf16.get_pixels(), pixbuf16.get_has_alpha(), pixbuf16.get_bits_per_sample(),
41
 
                            pixbuf16.get_width(), pixbuf16.get_height(), pixbuf16.get_rowstride())).replace\
42
 
-                     ('@PACKAGE_VERSION@', sys.argv[1]))
43
 
+                     ('@PACKAGE_VERSION@', sys.argv[1]).replace\
44
 
+                     ('@DESKTOP_FILE_DIR@', sys.argv[2]))
45