~ubuntu-branches/debian/sid/openbox/sid

« back to all changes in this revision

Viewing changes to debian/patches/08_fix_causing_submenuShowDelay.patch

  • Committer: Package Import Robot
  • Author(s): Mateusz Łukasik
  • Date: 2013-09-26 16:37:01 UTC
  • Revision ID: package-import@ubuntu.com-20130926163701-27qyhau4ttuf1luh
Tags: 3.5.2-2
* debian/control:
  + Replace ttf-dejavu with fonts-dejavu and add tint2 in suggests,
  + Add librsvg-2.0-dev for depends openbox-dev package. (Closes: #724059)
* Add lintian overrides for executable-not-elf-or-script.
* Add fix_center_window.patch from upstream to add the old center option.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix a typo causing submenuShowDelay to be ignored (Bug 6019)
2
 
diff --git a/openbox/menuframe.c b/openbox/menuframe.c
3
 
index b49a221..3252bb3 100644
4
 
--- a/openbox/menuframe.c
5
 
+++ b/openbox/menuframe.c
6
 
@@ -1242,9 +1242,9 @@ void menu_frame_select(ObMenuFrame *self, ObMenuEntryFrame *entry,
7
 
         if (self->selected->entry->type == OB_MENU_ENTRY_TYPE_SUBMENU) {
8
 
             /* only show if the submenu isn't already showing */
9
 
             if (oldchild_entry != self->selected) {
10
 
-                if (immediate || config_submenu_hide_delay == 0)
11
 
+                if (immediate || config_submenu_show_delay == 0)
12
 
                     menu_entry_frame_show_submenu(self->selected);
13
 
-                else if (config_submenu_hide_delay > 0) {
14
 
+                else if (config_submenu_show_delay > 0) {
15
 
                     if (submenu_show_timer)
16
 
                         g_source_remove(submenu_show_timer);
17
 
                     submenu_show_timer =