~ubuntu-branches/debian/sid/openchange/sid

« back to all changes in this revision

Viewing changes to debian/patches/02-schemaidguid-ldflags

  • Committer: Package Import Robot
  • Author(s): Jelmer Vernooij
  • Date: 2014-07-05 23:22:34 UTC
  • Revision ID: package-import@ubuntu.com-20140705232234-nte78ndg345bex7c
Tags: 1:2.1-3
* Set branch in Vcs-Git field.
* Add 02-schemaidguid-ldflags: Fixes hardening of schemaIDGUID binary.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
commit 13ca42f7e063c6a6b93cc9d1a02d6b54090427fd
 
2
Author: Jelmer Vernooij <jelmer@samba.org>
 
3
Date:   Mon Jul 7 04:04:28 2014 +0200
 
4
 
 
5
    Pass ldflags to linker when building schemaIDGUID.
 
6
 
 
7
diff --git a/Makefile b/Makefile
 
8
index 4f6d7fc..28f65e9 100644
 
9
--- a/Makefile
 
10
+++ b/Makefile
 
11
@@ -1410,7 +1410,7 @@ clean:: schemaIDGUID-clean
 
12
 
 
13
 bin/schemaIDGUID: utils/schemaIDGUID.o
 
14
        @echo "Linking $@"
 
15
-       @$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
 
16
+       @$(CC) $(CFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS)
 
17
 
 
18
 ###################
 
19
 # check_fasttransfer test app.