~ubuntu-branches/debian/sid/openjdk-7/sid

« back to all changes in this revision

Viewing changes to debian/patches/jamvm-avoid-version-soname.patch

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-09-04 17:55:43 UTC
  • Revision ID: package-import@ubuntu.com-20120904175543-jxrs4jn2gufu9z2t
Tags: 7u3-2.1.2-2
Pass -avoid-version to libtool to create a JamVM libjvm.so without SONAME
version numbers to match the Hotspot Server/Client libjvm.so. LP: #850433.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- jamvm/jamvm/src/Makefile.am.orig
 
2
+++ jamvm/jamvm/src/Makefile.am
 
3
@@ -41,6 +41,7 @@
 
4
 libjvm_la_SOURCES =
 
5
 
 
6
 jamvm_LDADD = libcore.la
 
7
+libjvm_la_LDFLAGS = -avoid-version
 
8
 libjvm_la_LIBADD = libcore.la
 
9
 libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \
 
10
                     os/@os@/libos.la classlib/@classlib@/libclasslib.la