~ubuntu-branches/debian/sid/openssh/sid

« back to all changes in this revision

Viewing changes to debian/patches/ssh-copy-id-status-check.patch

  • Committer: Bazaar Package Importer
  • Author(s): Colin Watson
  • Date: 2010-02-28 01:35:53 UTC
  • Revision ID: james.westby@ubuntu.com-20100228013553-gundr6k0iky9b7ih
Tags: 1:5.3p1-3
* Convert to source format 3.0 (quilt).
* Update README.source to match, and add a 'quilt-setup' target to
  debian/rules for the benefit of those checking out the package from
  revision control.
* All patches are now maintained separately and tagged according to DEP-3.
* Add GSSAPIStoreCredentialsOnRekey to 'sshd -T' configuration dump.
* Remove documentation of building for Debian 3.0 in README.Debian.
  Support for this was removed in 1:4.7p1-2.
* Remove obsolete header from README.Debian dating from when people
  expected non-free SSH.
* Update copyright years for GSSAPI patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: ssh-copy-id: Check exit status of 'ssh-add -L'
 
2
 This fixes behaviour when an agent is running with no identities loaded.
 
3
Author: Adeodato Simó <asp16@alu.ua.es>
 
4
Bug-Debian: http://bugs.debian.org/221675
 
5
Last-Update: 2010-02-27
 
6
 
 
7
Index: b/contrib/ssh-copy-id
 
8
===================================================================
 
9
--- a/contrib/ssh-copy-id
 
10
+++ b/contrib/ssh-copy-id
 
11
@@ -19,7 +19,7 @@
 
12
     shift         # and this should leave $1 as the target name
 
13
   fi
 
14
 else
 
15
-  if [ x$SSH_AUTH_SOCK != x ] ; then
 
16
+  if [ x$SSH_AUTH_SOCK != x ] && ssh-add -L >/dev/null 2>&1; then
 
17
     GET_ID="$GET_ID ssh-add -L"
 
18
   fi
 
19
 fi