~ubuntu-branches/debian/sid/xfce4-indicator-plugin/sid

« back to all changes in this revision

Viewing changes to debian/patches/02_menu_on_no-indicators.patch

  • Committer: Bazaar Package Importer
  • Author(s): Evgeni Golov
  • Date: 2010-07-14 09:35:08 UTC
  • Revision ID: james.westby@ubuntu.com-20100714093508-u6bgh24cbmaa3bw8
Tags: 0.0.1-2
* debian/control:
  + Add Provides: indicator-renderer
  + Add Recommends: indicator-messages
* debian/patches/02_menu_on_no-indicators.patch
  + Display a menu even when there are no indicators.        closes: #587167
* debian/patches/03_skip_pofiles_in_patches.patch
  + Split the POTFILES.skip patch out, list all changed files in there.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: add a menu in the case there are no indicators
 
2
Forwarded: Yes
 
3
Author: Evgeni Golov <evgeni@debian.org>
 
4
Bug-Debian: http://bugs.debian.org/587167
 
5
Last-Update: 2010-06-29
 
6
 
 
7
diff -r 630cdff47172 panel-plugin/indicator.c
 
8
--- a/panel-plugin/indicator.c  Mon Jun 07 11:12:31 2010 +0200
 
9
+++ b/panel-plugin/indicator.c  Tue Jun 29 08:42:35 2010 +0200
 
10
@@ -204,7 +204,8 @@
 
11
 
 
12
   if (indicators_loaded == 0) {
 
13
     /* A label to allow for click through */
 
14
-    indicator->item = gtk_label_new(_("No Indicators"));
 
15
+    indicator->item = xfce_create_panel_button();
 
16
+    gtk_button_set_label(indicator->item, _("No Indicators"));
 
17
     gtk_widget_show(indicator->item);
 
18
     gtk_container_add (GTK_CONTAINER (plugin), indicator->item);
 
19
   } else {
 
20
@@ -293,6 +294,7 @@
 
21
 
 
22
   /* show the panel's right-click menu on this menu */
 
23
   xfce_panel_plugin_add_action_widget (plugin, indicator->menu);
 
24
+  xfce_panel_plugin_add_action_widget (plugin, indicator->item);
 
25
 
 
26
   /* connect plugin signals */
 
27
   g_signal_connect (G_OBJECT (plugin), "free-data",