~ubuntu-branches/debian/sid/xiphos/sid

« back to all changes in this revision

Viewing changes to debian/patches/gre_version.patch

  • Committer: Bazaar Package Importer
  • Author(s): Mike Hommey
  • Date: 2009-10-10 18:49:57 UTC
  • mfrom: (4.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20091010184957-jmsvjvuyo9cmxzgl
* Non-maintainer upload for transition to xulrunner 1.9.1.
  (Closes: #548682)
* debian/rules: Use dh_xulrunner
* debian/control:
  - Build-depend on a xulrunner-dev that provides dh_xulrunner.
  - Build-depend on libglade2-dev. (Closes: #549788)
  - Don't build-depend on gnome-spell (Closes: #549084)
* debian/patches/gre_version.patch: Tighten the GREVersionRange.
* debian/patches/series: Added gre_version.patch.
* Rebuilding will get the proper libgtkhtml-editor0 dependencies.
  (Closes: #550301)
* Getting proper dependencies from dh_xulrunner, and tightening
  GREVersionRange should avoid segfault at startup. (Closes: #550041)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruN xiphos-3.1.1/src/gecko/gecko-utils.cpp xiphos-3.1.1.new/src/gecko/gecko-utils.cpp
 
2
--- xiphos-3.1.1/src/gecko/gecko-utils.cpp
 
3
+++ xiphos-3.1.1.new/src/gecko/gecko-utils.cpp
 
4
@@ -232,8 +232,8 @@
 
5
        nsresult rv;
 
6
 #ifdef XPCOM_GLUE
 
7
        static const GREVersionRange greVersion = {
 
8
-               "1.9a", PR_TRUE,
 
9
-               "2", PR_TRUE
 
10
+               "1.9.1", PR_TRUE,
 
11
+               "1.9.2", PR_FALSE
 
12
        };
 
13
        char xpcomLocation[PATH_MAX];
 
14
        rv = GRE_GetGREPathWithProperties(&greVersion, 1, nsnull, 0, xpcomLocation, sizeof (xpcomLocation));