~ubuntu-branches/debian/squeeze/erlang/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/build-options.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2010-03-09 17:34:57 UTC
  • mfrom: (10.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100309173457-4yd6hlcb2osfhx31
Tags: 1:13.b.4-dfsg-3
Manpages in section 1 are needed even if only arch-dependent packages are
built. So, re-enabled them.

Show diffs side-by-side

added added

removed removed

Lines of Context:
7
7
 
8
8
Also, add debug info to VM binaries if DEB_BUILD_OPTIONS contains "debug".
9
9
 
10
 
--- erlang-13.b.3-dfsg.orig/Makefile.in
11
 
+++ erlang-13.b.3-dfsg/Makefile.in
 
10
--- erlang-13.b.4-dfsg.orig/Makefile.in
 
11
+++ erlang-13.b.4-dfsg/Makefile.in
12
12
@@ -16,6 +16,9 @@
13
 
 # 
 
13
 #
14
14
 # %CopyrightEnd%
15
15
 
16
16
+ifeq ($(TYPE),debug)
19
19
 # Toplevel makefile for building the Erlang system
20
20
 #
21
21
 
22
 
--- erlang-13.b.3-dfsg.orig/erts/etc/common/Makefile.in
23
 
+++ erlang-13.b.3-dfsg/erts/etc/common/Makefile.in
24
 
@@ -494,13 +494,13 @@
 
22
--- erlang-13.b.4-dfsg.orig/erts/etc/common/Makefile.in
 
23
+++ erlang-13.b.4-dfsg/erts/etc/common/Makefile.in
 
24
@@ -491,13 +491,13 @@
25
25
 
26
26
 Install:       ../unix/Install.src ../../vsn.mk $(TARGET)/Makefile
27
27
        sed -e 's;%I_VSN%;$(VSN);' \
37
37
             -e 's;%EMULATOR_NUMBER%;$(EMULATOR_NUMBER);' \
38
38
             -e 's;%VSN%;$(VSN);' \
39
39
                   ../unix/erl.src.src > erl.src
40
 
--- erlang-13.b.3-dfsg.orig/erts/emulator/Makefile.in
41
 
+++ erlang-13.b.3-dfsg/erts/emulator/Makefile.in
42
 
@@ -258,7 +258,7 @@
 
40
--- erlang-13.b.4-dfsg.orig/erts/emulator/Makefile.in
 
41
+++ erlang-13.b.4-dfsg/erts/emulator/Makefile.in
 
42
@@ -262,7 +262,7 @@
43
43
 CS_CFLAGS = $(CS_CFLAGS_)
44
44
 endif
45
45
 CS_LDFLAGS = $(LDFLAGS)
48
48
 
49
49
 LIBS   += @TERMCAP_LIB@ -L../lib/internal/$(TARGET) @ERTS_INTERNAL_X_LIBS@
50
50
 
51
 
@@ -284,7 +284,7 @@
 
51
@@ -288,7 +288,7 @@
52
52
 LIBS    += $(ERL_TOP)/erts/emulator/pcre/obj/$(TARGET)/$(TYPE)/libepcre.a
53
53
 DEPLIBS += \
54
54
        $(ERL_TOP)/erts/emulator/pcre/obj/$(TARGET)/$(TYPE)/libepcre.a \
57
57
 # rem liberts_internal.a
58
58
 endif
59
59
 
60
 
--- erlang-13.b.3-dfsg.orig/make/otp.mk.in
61
 
+++ erlang-13.b.3-dfsg/make/otp.mk.in
62
 
@@ -71,18 +71,17 @@
 
60
--- erlang-13.b.4-dfsg.orig/make/otp.mk.in
 
61
+++ erlang-13.b.4-dfsg/make/otp.mk.in
 
62
@@ -72,18 +72,17 @@
63
63
 #      Erlang language section
64
64
 # ----------------------------------------------------
65
65
 EMULATOR = beam