~ubuntu-branches/debian/squeeze/erlang/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/sparc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2009-05-07 15:07:37 UTC
  • mfrom: (1.2.1 upstream) (5.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20090507150737-i4yb5elwinm7r0hc
Tags: 1:13.b-dfsg1-1
* Removed another bunch of non-free RFCs from original tarball
  (closes: #527053).
* Fixed build-dependencies list by adding missing comma. This requires
  libsctp-dev again. Also, added libsctp1 dependency to erlang-base and
  erlang-base-hipe packages because the shared library is loaded via
  dlopen now and cannot be added using dh_slibdeps (closes: #526682).
* Weakened dependency of erlang-webtool on erlang-observer to recommends
  to avoid circular dependencies (closes: #526627).
* Added solaris-i386 to HiPE enabled architectures.
* Made script sources in /usr/lib/erlang/erts-*/bin directory executable,
  which is more convenient if a user wants to create a target Erlang system.
* Shortened extended description line for erlang-dev package to make it
  fit 80x25 terminals.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
 
6
6
(2) Fixes FTBFS(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=328031).
7
7
 
8
 
--- erlang-12.b.5-dfsg.orig/erts/configure.in
9
 
+++ erlang-12.b.5-dfsg/erts/configure.in
10
 
@@ -430,7 +430,7 @@
11
 
 esac
12
 
 ARCH=noarch
13
 
 case `uname -m` in
14
 
-sun4u) ARCH=ultrasparc;;
15
 
+sun4u|sparc*)  ARCH=ultrasparc;;
16
 
 sparc64)       ARCH=sparc64;;
17
 
 sun4v) ARCH=ultrasparc;;
18
 
 i86pc) ARCH=x86;;
19
 
--- erlang-12.b.5-dfsg.orig/erts/emulator/beam/beam_emu.c
20
 
+++ erlang-12.b.5-dfsg/erts/emulator/beam/beam_emu.c
21
 
@@ -982,16 +982,6 @@
 
8
--- erlang-13.b-dfsg.orig/erts/configure.in
 
9
+++ erlang-13.b-dfsg/erts/configure.in
 
10
@@ -473,7 +473,7 @@
 
11
     chk_arch_=`uname -m`
 
12
 fi
 
13
 case $chk_arch_ in
 
14
-    sun4u)     ARCH=ultrasparc;;
 
15
+    sun4u|sparc*)      ARCH=ultrasparc;;
 
16
     sparc64)   ARCH=sparc64;;
 
17
     sun4v)     ARCH=ultrasparc;;
 
18
     i86pc)     ARCH=x86;;
 
19
--- erlang-13.b-dfsg.orig/erts/emulator/beam/beam_emu.c
 
20
+++ erlang-13.b-dfsg/erts/emulator/beam/beam_emu.c
 
21
@@ -1005,16 +1005,6 @@
22
22
  * in registers.
23
23
  */
24
24
 
35
35
 #  define REG_x0
36
36
 #  define REG_xregs
37
37
 #  define REG_htop
38
 
@@ -1000,7 +990,6 @@
 
38
@@ -1023,7 +1013,6 @@
39
39
 #  define REG_fcalls
40
40
 #  define REG_tmp_arg1
41
41
 #  define REG_tmp_arg2