~ubuntu-branches/debian/squeeze/ltsp/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/kfreebsd-ltsp-update-sshkeys.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Vagrant Cascadian
  • Date: 2010-02-19 00:13:14 UTC
  • mfrom: (34.2.37 upstream)
  • Revision ID: james.westby@ubuntu.com-20100219001314-fpq9nqjviqr4np56
Tags: 5.2-1
* New upstream version:
  - Many speed optimizations by using fewer calls to external binaries in
    shell scripts, and caching values when feasible.
  - More flexible sound configuration.
  - New screen scripts: ssh, menu and kiosk.
  - Greatly improved rewrite of remote apps support.
  - Updated Vietnamese (vi) translation by Clytie Siddall (Closes: #569156).
  - Add manpages for ltsp-remoteapps and ltsp-info.
  - Many speed improvements and bug fixes to nbd-proxy.

  - ltsp-build-client plugins: 
    + Added support for installing packages from backports.
    + When guessing a proxy, consider http_proxy=false to be no proxy.
    + squashfs-image: Only adjust the kernel version and include aufs modules
      when building a Lenny LTSP environment.

  - localapps: 
    + Fix LOCAL_APPS_EXTRAMOUNTS by quoting the sshfs arguments.
      Thanks to Adam J. Lincoln for the patch (LP: #521147).
    + Do not generate the localapps menu when running a fat client.

  - ltsp-update-sshkeys:
    + Add support for getting keys from application servers to be stored in
      the chroot. 

  - initramfs-tools hooks:
    + Only run nfs-bottom hook if configured as an ltsp_chroot.
    + Apply DNS info received from DHCP to /etc/resolv.conf.
    + Allow client hostnames to be specified from lts.conf.
    + Handle tmpfs bind mounts from the initramfs instead of from init script
      to ensure they're writeable very early.

  - ltsp-update-image:
    + Rewrite ltsp-update-image to more intelligently handle updating ports.
    + Source config files first so command line arguments can override. 

* Updated patches:
  - use-invokercd-initscripts
  - use-test-binary
  - kfreebsd-ltsp-update-sshkeys

* Drop patches, applied upstream:
  - handle-readonly-etc-cups
  - drop-aufs-modules-package
  - merge-configure-localdev-functions
  - writeable-var-cache-ltsp

* No longer ship /etc/default/ltsp-client-setup, as it is obsoleted in favor
  of using lts.conf configuration variables.

* ltsp-client-builder:
  - Redirect and close file descriptors for subshell running
    ltsp-build-client instead of only the call to ltsp-build-client, to make
    sure nothing leaks to debconf. Thanks to Petter Reinholdtsen.

* debian/control: 
  - Updated email address to use vagrant@debian.org.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
## DP: command from iproute.
7
7
 
8
8
@DPATCH@
9
 
diff -urNad ltsp-5.1.90~/server/ltsp-update-sshkeys ltsp-5.1.90/server/ltsp-update-sshkeys
10
 
--- ltsp-5.1.90~/server/ltsp-update-sshkeys     2009-10-04 08:53:44.000000000 -0700
11
 
+++ ltsp-5.1.90/server/ltsp-update-sshkeys      2009-10-04 08:54:31.000000000 -0700
12
 
@@ -68,7 +68,12 @@
13
 
               grep -v images)
14
 
 fi
15
 
 HOSTNAME=$(hostname)
16
 
-IPS=$(/sbin/ip -o -f inet addr show | sed -e 's,.* \(.*\)/.*,\1,' | grep -v '^127')
17
 
+if [ -x /sbin/ip ]; then
18
 
+    IPS=$(/sbin/ip -o -f inet addr show | sed -e 's,.* \(.*\)/.*,\1,' | grep -v '^127')
19
 
+elif [ -x /sbin/ifconfig ]; then
20
 
+    # this assumes freebsd-net-tools on a Debian GNU/kFreeBSD system
21
 
+    IPS=$(/sbin/ifconfig  | awk '/inet [1-9]/{print $2}' | egrep -v ^127)
22
 
+fi
23
 
 OUTPUT=$(mktemp)
24
 
 ENC="dsa rsa"
25
 
 NAMES="${HOSTNAME} ${IPS}"
 
9
diff -urNad ltsp-5.2~bzr1668~/server/ltsp-update-sshkeys ltsp-5.2~bzr1668/server/ltsp-update-sshkeys
 
10
--- ltsp-5.2~bzr1668~/server/ltsp-update-sshkeys        2010-02-15 11:36:35.000000000 -0800
 
11
+++ ltsp-5.2~bzr1668/server/ltsp-update-sshkeys 2010-02-16 21:35:27.000000000 -0800
 
12
@@ -76,7 +76,12 @@
 
13
 
 
14
 if [ -z "$*" ]; then
 
15
     HOSTNAME=$(hostname)
 
16
-    IPS=$(/sbin/ip -o -f inet addr show | sed -e 's,.* \(.*\)/.*,\1,' | grep -v '^127')
 
17
+    if [ -x /sbin/ip ]; then
 
18
+        IPS=$(/sbin/ip -o -f inet addr show | sed -e 's,.* \(.*\)/.*,\1,' | grep -v '^127')
 
19
+    elif [ -x /sbin/ifconfig ]; then
 
20
+        # this assumes freebsd-net-tools on a Debian GNU/kFreeBSD system
 
21
+        IPS=$(/sbin/ifconfig  | awk '/inet [1-9]/{print $2}' | egrep -v ^127)
 
22
+    fi
 
23
     NAMES="${HOSTNAME} ${IPS}"
 
24
 else
 
25
     # We were passed hostnames and ips