~ubuntu-branches/debian/squeeze/ntp/squeeze-201010051545

« back to all changes in this revision

Viewing changes to debian/patches/kfreebsd.patch

  • Committer: Bazaar Package Importer
  • Author(s): Kurt Roeckx
  • Date: 2009-11-26 22:16:37 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20091126221637-lbtdp0ax1yg9t0bx
Tags: 1:4.2.4p7+dfsg-4
* Use uname -s instead of dpkg-architecture to found the kernel we're
  running on.  dpkg-architecture is part of dpkg-dev. (Closes: #558145)
* Make the package fail to build on hurd since it does not provided
  the needed system calls for ntpd to work.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Aurelien Jarno <aurelien@aurel32.net>
 
2
Subject: Detect that the kernel has nano support or not.
 
3
Bug-Debian: http://bugs.debian.org/522696
 
4
 
 
5
 
 
6
Index: ntp-4.2.4p7+dfsg/configure.ac
 
7
===================================================================
 
8
--- ntp-4.2.4p7+dfsg.orig/configure.ac  2009-11-25 20:15:34.000000000 +0100
 
9
+++ ntp-4.2.4p7+dfsg/configure.ac       2009-11-25 20:16:30.000000000 +0100
 
10
@@ -760,16 +760,19 @@
 
11
     ac_cv_var_override_hz=yes
 
12
     ;;
 
13
  *-*-freebsd*)
 
14
     ac_cv_var_override_hz=yes
 
15
     ;;
 
16
  *-*-sunos4*)
 
17
     ac_cv_var_override_hz=yes
 
18
     ;;
 
19
+ *-*-kfreebsd*)
 
20
+    ac_cv_var_override_hz=yes
 
21
+    ;;
 
22
 esac])
 
23
 case "$ac_cv_var_override_hz" in
 
24
  yes)
 
25
     AC_DEFINE(OVERRIDE_HZ, 1, [Do we need to override the system's idea of HZ?])
 
26
     ;;
 
27
 esac
 
28
 
 
29
 dnl AC_CACHE_CHECK(ut_host in struct utmp, ac_cv_func_ut_host_in_utmp,
 
30
@@ -1776,16 +1779,19 @@
 
31
        ans=no
 
32
        ;;
 
33
      *-*-*linux*)
 
34
        ans=no
 
35
        ;;
 
36
      *-*-unicosmp*)
 
37
        ans=no
 
38
        ;;
 
39
+     *-*-kfreebsd*)
 
40
+       ans=no
 
41
+       ;;
 
42
     esac
 
43
     ;;
 
44
 esac
 
45
 ac_cv_var_signalled_io=$ans])
 
46
 case "$ac_cv_var_signalled_io" in
 
47
  yes) AC_DEFINE(HAVE_SIGNALED_IO, 1, [Can we use SIGIO for tcp and udp IO?]) ;;
 
48
 esac
 
49
 
 
50
@@ -1844,16 +1850,19 @@
 
51
        ans=no
 
52
        ;;
 
53
      *-*-ultrix*)
 
54
         ans=no
 
55
         ;;
 
56
      *-*-unicosmp*)
 
57
         ans=no
 
58
         ;;
 
59
+     *-*-kfreebsd*)
 
60
+       ans=no
 
61
+       ;;
 
62
      *) ans=yes
 
63
         ;;
 
64
     esac
 
65
     ;;
 
66
 esac
 
67
 ac_cv_var_use_udp_sigpoll=$ans])
 
68
 case "$ac_cv_var_use_udp_sigpoll" in
 
69
  yes) AC_DEFINE(USE_UDP_SIGPOLL, 1, [Can we use SIGPOLL for UDP?]) ;;
 
70
@@ -1895,16 +1904,19 @@
 
71
         ans=no
 
72
         ;;
 
73
      *-*-qnx*)
 
74
         ans=no
 
75
         ;;
 
76
      *-*-unicosmp*)
 
77
         ans=no
 
78
         ;;
 
79
+     *-*-kfreebsd*)
 
80
+       ans=no
 
81
+       ;;
 
82
      *) ans=yes
 
83
         ;;
 
84
     esac
 
85
     ;;
 
86
 esac
 
87
 ac_cv_var_use_tty_sigpoll=$ans])
 
88
 case "$ac_cv_var_use_tty_sigpoll" in
 
89
  yes) AC_DEFINE(USE_TTY_SIGPOLL, 1, [Can we use SIGPOLL for tty IO?]) ;;