~ubuntu-branches/debian/squeeze/pyopencl/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/python-versions.patch

  • Committer: Bazaar Package Importer
  • Author(s): Tomasz Rybak
  • Date: 2010-05-31 19:29:00 UTC
  • Revision ID: james.westby@ubuntu.com-20100531192900-3vv2wuddhh6r2sxw
Tags: 0.92~beta+git20100709-1
* Initial release
* Replaced usage of setuptools with python-setuptools from Debian
* Deleted jquery.js and replace it with link to script from libjs-jquery

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Change option providing name of Python Boost library
 
2
 Package needs libboost-python and name of linked library depends on Python
 
3
 version. To build for all supported Python version we need to get used
 
4
 Python version and include it into name of linked library.
 
5
Forwarded: not-needed
 
6
Author: Tomasz Rybak <bogomips@post.pl>
 
7
Last-Update: 2010-06-19
 
8
Index: pyopencl-0.92~beta+git20100618/setup.py
 
9
===================================================================
 
10
--- pyopencl-0.92~beta+git20100618.orig/setup.py        2010-06-19 20:30:40.000000000 +0200
 
11
+++ pyopencl-0.92~beta+git20100618/setup.py     2010-06-19 20:31:07.000000000 +0200
 
12
@@ -42,6 +42,7 @@
 
13
 
 
14
 def main():
 
15
     import glob
 
16
+    import sys
 
17
     from aksetup_helper import (hack_distutils, get_config, setup,
 
18
             NumpyExtension, set_up_shipped_boost_if_requested)
 
19
 
 
20
@@ -53,6 +54,7 @@
 
21
     EXTRA_OBJECTS, EXTRA_DEFINES = set_up_shipped_boost_if_requested(conf)
 
22
 
 
23
     LIBRARY_DIRS = conf["BOOST_LIB_DIR"]
 
24
+    conf["BOOST_PYTHON_LIBNAME"][0] += sys.version[0]+sys.version[2]
 
25
     LIBRARIES = conf["BOOST_PYTHON_LIBNAME"]
 
26
 
 
27
     from os.path import dirname, join, normpath