~ubuntu-branches/debian/squeeze/rdesktop/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/35_force_rdpdr.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Laszlo Boszormenyi (GCS), Patrick Calhoun, Laszlo Boszormenyi
  • Date: 2009-08-20 23:07:08 UTC
  • Revision ID: james.westby@ubuntu.com-20090820230708-f5l8hezw5i01s4na
Tags: 1.6.0-3
[ Patrick Calhoun ]
* debian/patches/35_force_rdpdr.dpatch: Backported patch From Sameer Naik to
  init rdpdr. ( http://article.gmane.org/gmane.network.rdesktop.devel/2808 )
* debian/patches/32_it_keymap.dpatch: Italian keymap (closes: #540352).
* debian/patches/80_config.dpatch: use autotools config.guess, config.sub
  (moved script from debian/rules to the dpatch system)
* Compile with alsa sound support enabled (closes: #507654).
* Added libasound2-dev, dpatch (>= 2.0.9) to build-depends
* Update debhelper-compat to 6 (was 4) , no changes needed.
* Modified debian/rules to build using dpatch

[ Laszlo Boszormenyi ]
* Added watch file (closes: #519065).
* Moved nostrip option handling to 80_handle_nostrip_option.dpatch as using
  dpatch now.
* Added pkg-config to build-depends, needs for detecting ALSA availability.
* Updated Standards-Version to 3.8.2 , no changes needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## force_rdpdr.dpatch by Patrick Calhoun <phineas@ou.edu>
 
3
## (Original patch by Sameer Naik)
 
4
## 
 
5
## All lines beginning with `## DP:' are a description of the patch.
 
6
## DP: Initializes the rdpdr channel whether or not any devices are being
 
7
## DP: redirected. As a result of this patch audio playback works when connected
 
8
## DP: to a vista (_w SP1) machine using rdesktop client.
 
9
 
 
10
@DPATCH@
 
11
diff -urNad rdesktop-1.6.0~/rdpdr.c rdesktop-1.6.0/rdpdr.c
 
12
--- rdesktop-1.6.0~/rdpdr.c     2008-02-14 05:37:17.000000000 -0600
 
13
+++ rdesktop-1.6.0/rdpdr.c      2009-08-19 14:50:35.000000000 -0500
 
14
@@ -841,13 +841,10 @@
 
15
 RD_BOOL
 
16
 rdpdr_init()
 
17
 {
 
18
-       if (g_num_devices > 0)
 
19
-       {
 
20
-               rdpdr_channel =
 
21
-                       channel_register("rdpdr",
 
22
-                                        CHANNEL_OPTION_INITIALIZED | CHANNEL_OPTION_COMPRESS_RDP,
 
23
-                                        rdpdr_process);
 
24
-       }
 
25
+       rdpdr_channel =
 
26
+               channel_register("rdpdr",
 
27
+                                CHANNEL_OPTION_INITIALIZED | CHANNEL_OPTION_COMPRESS_RDP,
 
28
+                                rdpdr_process);
 
29
 
 
30
        return (rdpdr_channel != NULL);
 
31
 }