~ubuntu-branches/debian/squeeze/sdl-ttf2.0/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/freetype-fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jerome Marant
  • Date: 2004-01-10 14:59:22 UTC
  • Revision ID: james.westby@ubuntu.com-20040110145922-2ia3lqbxuzo0k7lf
Tags: 2.0.6-5
* debian/control:
  - Changed Section field of libsdl-ttf2.0-dev from libs to libdevel. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
##
 
3
## DP: patch fixing a build failure with last version of Freetype.
 
4
## DP: by Daniel Schepler <schepler@math.berkeley.edu>
 
5
 
 
6
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
7
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
8
 
 
9
if [ $# -ne 1 ]; then
 
10
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
11
    exit 1
 
12
fi
 
13
case "$1" in
 
14
       -patch) patch $patch_opts -p1 < $0;;
 
15
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
16
        *)
 
17
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
18
                exit 1;;
 
19
esac
 
20
 
 
21
exit 0
 
22
@DPATCH@
 
23
--- sdl-ttf2.0-2.0.6.old/SDL_ttf.c      2004-01-09 21:13:02.573965462 -0800
 
24
+++ sdl-ttf2.0-2.0.6/SDL_ttf.c  2004-01-09 21:11:43.509597069 -0800
 
25
@@ -39,10 +39,12 @@
 
26
 #define FREEA(p) free(p)
 
27
 #endif
 
28
 
 
29
-#include <freetype/freetype.h>
 
30
-#include <freetype/ftoutln.h>
 
31
-#include <freetype/ttnameid.h>
 
32
-#include <freetype/internal/ftobjs.h>
 
33
+#include <ft2build.h>
 
34
+#include FT_FREETYPE_H
 
35
+#include FT_OUTLINE_H
 
36
+#include FT_TRUETYPE_IDS_H
 
37
+#include FT_INTERNAL_INTERNAL_H
 
38
+#include FT_INTERNAL_OBJECTS_H
 
39
 
 
40
 #include "SDL.h"
 
41
 #include "SDL_endian.h"
 
42
@@ -172,7 +174,7 @@
 
43
          int          err_code;
 
44
          const char*  err_msg;
 
45
        } ft_errors[] = {
 
46
-#include <freetype/fterrors.h>
 
47
+#include FT_ERRORS_H
 
48
        };
 
49
        int i;
 
50
        const char *err_msg;