~ubuntu-branches/debian/stretch/clalsadrv/stretch

« back to all changes in this revision

Viewing changes to debian/patches/01-makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2010-03-17 20:29:56 UTC
  • mto: This revision was merged to the branch mainline in revision 9.
  • Revision ID: james.westby@ubuntu.com-20100317202956-4do8y4y5yan1ev3z
Tags: 1.2.2-2
* Switch to debhelper 7.
* Replace dpatch with quilt, convert all patches to the quilt format.
* debian/control:
  - Set maintainer to Debian Multimedia Maintainers.
  - Add myself to the Uploaders list.
  - Set DM-Upload-Allowed to yes.
  - Bump Standards-Version.
  - Add missing  macro to libclalsadrv-dev Depends field.
  - Add Homepage field.
  - Adjust Section fields properly.
  - Replace deprecated Source-Version substvar with binary:Version.
  - Improve long description.
* debian/patches/01-makefile.patch:
  - Create /usr/include, otherwise doesn't install the headers.
  - Add comments as per DEP-3.
* Remove unnecessary .dirs files, update .install files.
* Update debian/copyright as per DEP-5 spec.
* debian/README.source: Document how to patch the sources.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Free Ekanayaka <freee@debian.org>
 
2
Description: Set PREFIX properly, add DESTDIR var, create /usr/include
 
3
 before installing the headers.
 
4
---
 
5
 Makefile |    6 ++++--
 
6
 1 file changed, 4 insertions(+), 2 deletions(-)
 
7
 
 
8
--- clalsadrv.orig/Makefile
 
9
+++ clalsadrv/Makefile
 
10
@@ -14,11 +14,12 @@
 
11
 #  along with this program; if not, write to the Free Software
 
12
 #  Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
13
 
 
14
+DESTDIR =
 
15
 
 
16
 # Modify as required.
 
17
 #
 
18
-PREFIX = /usr
 
19
-SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
 
20
+PREFIX = $(DESTDIR)/usr
 
21
+#SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
 
22
 LIBDIR = lib$(SUFFIX)
 
23
 
 
24
 
 
25
@@ -47,6 +48,7 @@ $(CLALSADRV_MIN): $(CLALSADRV_O)
 
26
 
 
27
 install:       $(CLALSADRV_MIN)
 
28
        /usr/bin/install -d $(PREFIX)/$(LIBDIR)
 
29
+       /usr/bin/install -d $(PREFIX)/include
 
30
        /usr/bin/install -m 644 $(CLALSADRV_H) $(PREFIX)/include
 
31
        /usr/bin/install -m 755 $(CLALSADRV_MIN) $(PREFIX)/$(LIBDIR)
 
32
        /sbin/ldconfig -n $(PREFIX)/$(LIBDIR)