~ubuntu-branches/debian/stretch/clalsadrv/stretch

« back to all changes in this revision

Viewing changes to debian/patches/makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2010-03-17 20:29:56 UTC
  • mfrom: (2.1.3 sid)
  • Revision ID: james.westby@ubuntu.com-20100317202956-jakg8sfos4sjl9dx
* Switch to debhelper 7.
* Replace dpatch with quilt, convert all patches to the quilt format.
* debian/control:
  - Set maintainer to Debian Multimedia Maintainers.
  - Add myself to the Uploaders list.
  - Set DM-Upload-Allowed to yes.
  - Bump Standards-Version.
  - Add missing  macro to libclalsadrv-dev Depends field.
  - Add Homepage field.
  - Adjust Section fields properly.
  - Replace deprecated Source-Version substvar with binary:Version.
  - Improve long description.
* debian/patches/01-makefile.patch:
  - Create /usr/include, otherwise doesn't install the headers.
  - Add comments as per DEP-3.
* Remove unnecessary .dirs files, update .install files.
* Update debian/copyright as per DEP-5 spec.
* debian/README.source: Document how to patch the sources.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## makefile.dpatch by  <@localhost.localdomain>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad clalsadrv-1.1.0+1~/Makefile clalsadrv-1.1.0+1/Makefile
9
 
--- a/Makefile  2007-03-16 10:57:43.000000000 +0000
10
 
+++ b/Makefile  2007-05-24 09:57:30.000000000 +0000
11
 
@@ -14,11 +14,12 @@
12
 
 #  along with this program; if not, write to the Free Software
13
 
 #  Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
14
 
 
15
 
+DESTDIR =
16
 
 
17
 
 # Modify as required.
18
 
 #
19
 
-PREFIX = /usr
20
 
-SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
21
 
+PREFIX = $(DESTDIR)/usr
22
 
+#SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
23
 
 LIBDIR = lib$(SUFFIX)
24
 
 
25