~ubuntu-branches/debian/stretch/connectome-workbench/stretch

« back to all changes in this revision

Viewing changes to debian/patches/deb_system_ftgl

  • Committer: Package Import Robot
  • Author(s): Yaroslav Halchenko
  • Date: 2014-10-21 10:04:22 UTC
  • Revision ID: package-import@ubuntu.com-20141021100422-mh7mwoe3hemux3gh
Tags: 1.0-2
* debian/copyright
  - additional/adjusted entries. Thanks Thorsten
    Alteholz for the review
* Re-upload to Debian proper (Closes: #744130)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/src/CMakeLists.txt
 
2
+++ b/src/CMakeLists.txt
 
3
@@ -241,7 +241,7 @@ SET(FTGL_FONT_MODULE_FOR_LINKING "")
 
4
 
 
5
 FIND_PACKAGE(Freetype)
 
6
 IF (FREETYPE_FOUND)
 
7
-    SET (FTGL_FONT_MODULE_FOR_LINKING FtglFont)
 
8
+    SET (FTGL_FONT_MODULE_FOR_LINKING ftgl)
 
9
     MESSAGE("FreeType library found")
 
10
     MESSAGE("   INCLUDES ${FREETYPE_INCLUDE_DIRS}")
 
11
     MESSAGE("   INCLUDES_FT2_BUILD ${FREETYPE_INCLUDE_DIR_ft2build}")
 
12
@@ -323,7 +323,8 @@ ADD_SUBDIRECTORY ( Xml )
 
13
 ADD_SUBDIRECTORY ( Scenes )
 
14
 ADD_SUBDIRECTORY ( OSMesaDummy )
 
15
 IF (FREETYPE_FOUND)
 
16
-    ADD_SUBDIRECTORY ( FtglFont )
 
17
+    # yoh: Use system-installed libftgl
 
18
+    #ADD_SUBDIRECTORY ( FtglFont )
 
19
 ENDIF (FREETYPE_FOUND)
 
20
 ADD_SUBDIRECTORY ( Charting )
 
21
 ADD_SUBDIRECTORY ( Palette )
 
22
--- a/src/Brain/CMakeLists.txt
 
23
+++ b/src/Brain/CMakeLists.txt
 
24
@@ -299,8 +299,10 @@ ${CMAKE_SOURCE_DIR}/Common
 
25
 
 
26
 IF (FREETYPE_FOUND)
 
27
 INCLUDE_DIRECTORIES(
 
28
-   ${CMAKE_SOURCE_DIR}/FtglFont
 
29
-   ${CMAKE_SOURCE_DIR}/FtglFont/FTGL
 
30
+   # yoh: use system-installed version of the library on Debian builds
 
31
+   /usr/include/FTGL
 
32
+   #${CMAKE_SOURCE_DIR}/FtglFont
 
33
+   #${CMAKE_SOURCE_DIR}/FtglFont/FTGL
 
34
    ${FREETYPE_INCLUDE_DIR_ft2build}
 
35
    ${FREETYPE_INCLUDE_DIR_freetype2}
 
36
 )
 
37
--- a/src/Brain/FtglFontTextRenderer.cxx
 
38
+++ b/src/Brain/FtglFontTextRenderer.cxx
 
39
@@ -70,7 +70,8 @@
 
40
 #include "CaretOpenGLInclude.h"
 
41
 
 
42
 #ifdef HAVE_FREETYPE
 
43
-#include <FtglConfig.h>
 
44
+/* yoh: disabling use of the original FTGL configuration file
 
45
+ #include <FtglConfig.h> */
 
46
 #include <FTGL/ftgl.h>
 
47
 using namespace FTGL;
 
48
 #endif // HAVE_FREETYPE