~ubuntu-branches/debian/stretch/input-utils/stretch

« back to all changes in this revision

Viewing changes to debian/patches/use-system-input.h

  • Committer: Bazaar Package Importer
  • Author(s): Marcus Better, Steve Langasek, Marcus Better
  • Date: 2010-08-02 22:16:30 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20100802221630-mf73m64mow67w8f6
Tags: 0.0.20081014-1
[ Steve Langasek ]
* debian/patches/show-numeric-key-values: always output the numeric
  value for keycodes in addition to the symbolic name
* debian/control: Vcs-Browser, not Vcs-Browse.
* debian/patches/stdout-not-stderr: informational messages should
  always go to stdout by convention, only errors to stderr.
  LP: #307513.

[ Marcus Better ]
* New upstream version.
* debian/rules: convert to debhelper 7.
* debian/control: bump Standards-Version to 3.9.1 (no changes).
* Switch to dpkg-source 3.0 (quilt) format
* debian/copyright: DEP-5 copyright format.
* DEP-3 patch format.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Marcus Better <marcus@better.se>
 
2
Subject: use up-to-date input.h from linux-libc-dev
 
3
Bug-Debian: http://bugs.debian.org/447550
 
4
Forwarded: not-needed
 
5
 
 
6
---
1
7
Index: input-utils/input.h
2
8
===================================================================
3
 
--- input-utils.orig/input.h    2007-10-29 16:54:03.189246570 +0100
4
 
+++ input-utils/input.h 2007-10-29 16:54:24.380047606 +0100
 
9
--- input-utils.orig/input.h    2010-08-02 10:37:58.000000000 +0200
 
10
+++ input-utils/input.h 2010-08-02 12:42:22.000000000 +0200
5
11
@@ -1,7 +1,7 @@
6
12
 #include <inttypes.h>
7
13
 
10
16
+#include <linux/input.h>
11
17
 
12
18
 #define ev_name(code)  ((code) < EV_MAX  && EV_NAME[code]  ? EV_NAME[code]  : "???")
13
 
 #define rel_name(code) ((code) < REL_MAX && REL_NAME[code] ? REL_NAME[code] : "???")
 
19
 #define ev_type_name(type, code) ((code) < EV_TYPE_MAX[type] && EV_TYPE_NAME[type][code] ? EV_TYPE_NAME[type][code] : "???")
14
20
Index: input-utils/lirc.sh
15
21
===================================================================
16
 
--- input-utils.orig/lirc.sh    2007-10-29 16:54:03.226244509 +0100
17
 
+++ input-utils/lirc.sh 2007-10-29 16:54:37.362294465 +0100
 
22
--- input-utils.orig/lirc.sh    2010-08-02 10:37:38.000000000 +0200
 
23
+++ input-utils/lirc.sh 2010-08-02 12:42:22.000000000 +0200
18
24
@@ -1,5 +1,5 @@
19
25
 #!/bin/sh
20
26
-INPUT="linux-input.h"
24
30
        name linux-input-layer
25
31
Index: input-utils/name.sh
26
32
===================================================================
27
 
--- input-utils.orig/name.sh    2007-10-29 16:54:03.251243116 +0100
28
 
+++ input-utils/name.sh 2007-10-29 16:54:41.922026634 +0100
 
33
--- input-utils.orig/name.sh    2010-08-02 10:37:38.000000000 +0200
 
34
+++ input-utils/name.sh 2010-08-02 12:42:22.000000000 +0200
29
35
@@ -1,7 +1,7 @@
30
36
 #!/bin/sh
31
37