~ubuntu-branches/debian/stretch/prips/stretch

« back to all changes in this revision

Viewing changes to debian/patches/05_fix_usage_multiline_string.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Juan Alvarez
  • Date: 2009-07-21 13:05:42 UTC
  • Revision ID: james.westby@ubuntu.com-20090721130542-zun03dm77oslp3h5
Tags: 0.9.4-3
* Fix multiline string. Closes: #195017
* Patches are now applied with dpatch.
* Install the new manpage from dpatch.
* Leave the Makefile clean and install the binaries from debian/rules.
* Update Standards-Version to 3.6.0

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## by Juan Alvarez <jalvarez@fluidsignal.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fix the multiline strings
 
6
## DP: Thanks to Joshua Kwan <joshk@triplehelix.org>
 
7
                                                                                                              
 
8
if [ $# -ne 1 ]; then
 
9
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
10
    exit 1
 
11
fi
 
12
 
 
13
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
14
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
15
 
 
16
case "$1" in
 
17
       -patch) patch $patch_opts -p1 < $0;;
 
18
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
19
        *)
 
20
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
21
                exit 1;;
 
22
esac
 
23
                                                                                                              
 
24
exit 0
 
25
@DPATCH@
 
26
--- prips-0.9.4/main.c          1999-12-13 20:15:42.000000000 -0800
 
27
+++ prips-0.9.4/main.c.new      2003-06-04 14:57:56.000000000 -0700
 
28
@@ -16,10 +16,10 @@
 
29
 
 
30
 const char *MAINTAINER = "dan@vertekcorp.com";
 
31
 const char *VERSION =
 
32
-       "\rprips 0.9.4
 
33
-       \rThis program comes with NO WARRANTY,
 
34
-       \rto the extent permitted by law.
 
35
-       \rYou may redistribute copies under 
 
36
+       "\rprips 0.9.4\n\
 
37
+       \rThis program comes with NO WARRANTY,\n\
 
38
+       \rto the extent permitted by law.\n\
 
39
+       \rYou may redistribute copies under \n\
 
40
        \rthe terms of the GNU General Public License.\n";
 
41
 
 
42
 void usage(char *prog);
 
43
@@ -166,13 +166,13 @@
 
44
 
 
45
 void usage(char *prog)
 
46
 {
 
47
-       fprintf(stderr, "usage: %s [options] <start end | CIDR block>
 
48
-       -c              print range in CIDR notation
 
49
-       -d <x>          set the delimeter 'x' where 0 =< x =< 255 
 
50
-       -f <x>          set the format of addresses (hex, dec, or dot)
 
51
-       -i <x>          set the increment to 'x'
 
52
-       -e <x.x.x,x.x>  e.g. -e ..4. will not print 192.168.4.[0-255]
 
53
-       
 
54
+       fprintf(stderr, "usage: %s [options] <start end | CIDR block>\n\
 
55
+       -c              print range in CIDR notation\n\
 
56
+       -d <x>          set the delimeter 'x' where 0 =< x =< 255 \n\
 
57
+       -f <x>          set the format of addresses (hex, dec, or dot)\n\
 
58
+       -i <x>          set the increment to 'x'\n\
 
59
+       -e <x.x.x,x.x>  e.g. -e ..4. will not print 192.168.4.[0-255]\n\
 
60
+       \n\
 
61
        \rReport bugs to %s\n",
 
62
                        prog, MAINTAINER);
 
63
 }