~ubuntu-branches/debian/stretch/sensors-applet/stretch

« back to all changes in this revision

Viewing changes to debian/patches/libnotify_0.7_api_change

  • Committer: Package Import Robot
  • Author(s): Jordi Mallach
  • Date: 2011-11-05 14:53:12 UTC
  • mfrom: (1.2.7)
  • Revision ID: package-import@ubuntu.com-20111105145312-pce58z1ov0rc9moq
Tags: 3.0.0-0.1
* Non-maintainer upload.
* New upstream release, with support for GNOME3 Panel (closes: #638099).
* Drop link-to-libdl and libnotify_0.7_api_change patches, applied
  upstream.
* Drop dh_autoreconf and all bootstrap friends from Build-Depends and
  Build-Conflicts, not needed anymore.
* Update Build-Depends for the GTK+3 port, as per configure.ac.
* Drop .a and .la files (closes: #633257).
* Build-Depend on libsensors4 for kfreebsd again, as the package is now
* available on that architecture.
* Avoid hardcoding architecture names for libatamart-dev, and drop it
  entirely for libsensors4, as all architectures should be supported,
  even if the Hurd isn't available yet (closes: #634515).
* As libsensors-applet-plugin hasn't bumped its sonames but has at least
  got an ABI break (due to the switch to GTK+3), and given there are no
  external rdepends, avoid a library rename by bumping its shlibs and
  adding Breaks: sensor-applets (<< 3.0.0).
* Change install path for the applet binary, and remove obsolete dirs.
* Tighten sensors-applet dependency on libsensors-applet-plugin to
  (= ${binary:Version}), just in case.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Port sensors-applet to the new libnotify 0.7 API
2
 
 Version 0.7 of libnotify drops an argument from the notify_notification_new()
3
 
 call; fix up our invocation accordingly.
4
 
Author: Steve Langasek <steve.langasek@canonical.com>
5
 
Bug-Debian: http://bugs.debian.org/630301
6
 
 
7
 
Index: sensors-applet-2.2.7/sensors-applet/sensors-applet.c
8
 
===================================================================
9
 
--- sensors-applet-2.2.7.orig/sensors-applet/sensors-applet.c
10
 
+++ sensors-applet-2.2.7/sensors-applet/sensors-applet.c
11
 
@@ -306,8 +306,7 @@
12
 
         
13
 
         sensors_applet->notification = notify_notification_new(summary,
14
 
                                                                message,
15
 
-                                                               GTK_STOCK_DIALOG_WARNING,
16
 
-                                                               GTK_WIDGET(sensors_applet->applet));
17
 
+                                                               GTK_STOCK_DIALOG_WARNING);
18
 
         g_free(summary);
19
 
         g_free(message);
20
 
         
21
 
Index: sensors-applet-2.2.7/sensors-applet/active-sensor-libnotify.c
22
 
===================================================================
23
 
--- sensors-applet-2.2.7.orig/sensors-applet/active-sensor-libnotify.c
24
 
+++ sensors-applet-2.2.7/sensors-applet/active-sensor-libnotify.c
25
 
@@ -86,8 +86,7 @@
26
 
         g_debug("Creating new notification");
27
 
         active_sensor->notification[notif_type] = notify_notification_new(summary,
28
 
                                                                           message,
29
 
-                                                                          icon_filename,
30
 
-                                                                          attach);
31
 
+                                                                          icon_filename);
32
 
         g_signal_connect(active_sensor->notification[notif_type], "closed",
33
 
                          G_CALLBACK(notif_closed_cb),
34
 
                          active_sensor);
35
 
--- sensors-applet-2.2.7.orig/po/POTFILES.skip
36
 
+++ sensors-applet-2.2.7/po/POTFILES.skip
37
 
@@ -1 +1,3 @@
38
 
 SensorsApplet.server.in
39
 
+.pc/libnotify_0.7_api_change/sensors-applet/sensors-applet.c
40
 
+