~ubuntu-branches/debian/wheezy/apache2/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/057_disablemods.dpatch

  • Committer: Package Import Robot
  • Author(s): Stefan Fritsch, Stefan Fritsch, Arno Töll
  • Date: 2011-12-29 12:09:14 UTC
  • Revision ID: package-import@ubuntu.com-20111229120914-hv1j5bee6zhw8bjf
Tags: 2.2.21-4
[ Stefan Fritsch ]

* Security: Fix broken patch for CVE-2011-3607 (Integer overflow in
  ap_pregsub).
* Optimize debian/rules again to improve build time by doing most work in a
  single parallelized "build-%" target.

[ Arno Töll ]

* Fix "Suggest removing DefaultType from apache2.conf" change the DefaultType
  from text/plain to None. This lets the browser guess a proper MIME type
  instead of being forced to treat a given file according to our default type
  (Closes: #440058)
* Fix "add pre-rotate hook to logrotate script" execute scripts in
  /etc/logrotate.d/httpd-prerotate if available (Closes: #590096).
* Fix "Hide /icons index" Disables indexes on the icon directory. By upgrading
  to Debian's 3.0/quilt source format also images don't need to be generated
  at build time anymore. Hence, the icon date can no longer lead to
  information disclosure (Closes: #649888).
* Upgrade package to 3.0/quilt.
  + Remove uuencoded images, keep them in their binary format in debian/icons
  + Upgrade to quilt from dpatch and refresh all patches by keeping all hunks
    unchanged. Remove the `001_branding' patch by supplying -DPLATFORM at
    build time where needed Move the 200_cp_suexec.dpatch patch and
    202_suexec-custom.dpatch patch to debian/rules. 200_cp_suexec.dpatch was a
    script, not a patch which is not supported by quilt.
* Rewrite debian/rules and base it on dh(1).
  + use overrides where possible, replace some debhelper calls by our own
    implementation where needed. That's required since the Apache package is
    compiled in parts several times for each MPM once.
  + move some install operations to the their respective .install files
  + Support dpkg-buildflags now, which also enables by default hardening
    flags. Thus, remove them from their explicit appearance in debian/rules
  + Remove DEB_BUILD_OPTIONS legacy support. It comes for free when using
    dh(1)/dpkg-buildflags(1).
* Push debhelper compatibility to 8
* Remove unused Lintian overrides for the Debian source package remove and
  redundant priorities in debian/control.
* Add myself to Uploaders

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## Stolen from the fedora package
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Support "--enable-modules=none" to build an httpd binary with 
6
 
## DP: no optional modules enabled.
7
 
 
8
 
@DPATCH@
9
 
diff -urNad trunk~/acinclude.m4 trunk/acinclude.m4
10
 
--- trunk~/acinclude.m4 2005-11-13 07:33:15.000000000 +0100
11
 
+++ trunk/acinclude.m4  2008-03-14 01:28:42.379287995 +0100
12
 
@@ -289,14 +289,19 @@
13
 
 
14
 
   AC_ARG_ENABLE(modules,
15
 
   APACHE_HELP_STRING(--enable-modules=MODULE-LIST,Space-separated list of modules to enable | "all" | "most"),[
16
 
-    for i in $enableval; do
17
 
-      if test "$i" = "all" -o "$i" = "most"; then
18
 
-        module_selection=$i
19
 
-      else
20
 
-        i=`echo $i | sed 's/-/_/g'`
21
 
-        eval "enable_$i=yes"
22
 
-      fi
23
 
-    done
24
 
+    if test "$enableval" = "none"; then
25
 
+       module_default=no
26
 
+       module_selection=none
27
 
+    else
28
 
+      for i in $enableval; do
29
 
+        if test "$i" = "all" -o "$i" = "most"; then
30
 
+          module_selection=$i
31
 
+        else
32
 
+          i=`echo $i | sed 's/-/_/g'`
33
 
+          eval "enable_$i=yes"
34
 
+        fi
35
 
+      done
36
 
+    fi
37
 
   ])
38
 
   
39
 
   AC_ARG_ENABLE(mods-shared,
40
 
diff -urNad trunk~/configure trunk/configure
41
 
--- trunk~/configure    2008-01-10 17:54:40.000000000 +0100
42
 
+++ trunk/configure     2008-03-14 01:31:55.675287371 +0100
43
 
@@ -8106,6 +8106,10 @@
44
 
   # Check whether --enable-modules was given.
45
 
 if test "${enable_modules+set}" = set; then
46
 
   enableval=$enable_modules;
47
 
+  if test "$enableval" = "none"; then
48
 
+     module_default=no
49
 
+     module_selection=none
50
 
+  else
51
 
     for i in $enableval; do
52
 
       if test "$i" = "all" -o "$i" = "most"; then
53
 
         module_selection=$i
54
 
@@ -8114,7 +8118,7 @@
55
 
         eval "enable_$i=yes"
56
 
       fi
57
 
     done
58
 
-
59
 
+  fi
60
 
 fi
61
 
 
62