~ubuntu-branches/debian/wheezy/w3m/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/060_format-security.patch

  • Committer: Package Import Robot
  • Author(s): Tatsuya Kinoshita
  • Date: 2011-10-30 15:23:40 UTC
  • Revision ID: package-import@ubuntu.com-20111030152340-drj5v1w5tpoxrqno
Tags: 0.5.3-4
* debian/patches/060_format-security.patch: Patch from 0.5.3-3ubuntu1 to
  appease gcc -Werror=format-security, provided by Colin Watson.
  (closes: #646321)
* debian/control: Use linux-any to depend on a Linux-specific package.
  (closes: #634340)
* debian/copyright: Appease missing-license-paragraph-in-dep5-copyright.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Appease gcc -Werror=format-security
 
2
Author: Colin Watson <cjwatson@ubuntu.com>
 
3
Forwarded: no
 
4
Last-Update: 2011-10-23
 
5
 
 
6
Index: b/acinclude.m4
 
7
===================================================================
 
8
--- a/acinclude.m4
 
9
+++ b/acinclude.m4
 
10
@@ -866,7 +866,7 @@
 
11
 AC_TRY_COMPILE(
 
12
 changequote(<<,>>)dnl
 
13
 <<extern char *sys_errlist[];>>,
 
14
-<<printf(sys_errlist[0]);>>,
 
15
+<<printf("%s", sys_errlist[0]);>>,
 
16
 changequote([,])dnl
 
17
 [have_sys_errlist="yes"; AC_DEFINE(HAVE_SYS_ERRLIST)],
 
18
 [have_sys_errlist="no"])
 
19
Index: b/configure
 
20
===================================================================
 
21
--- a/configure
 
22
+++ b/configure
 
23
@@ -8986,7 +8986,7 @@
 
24
 int
 
25
 main ()
 
26
 {
 
27
-printf(sys_errlist[0]);
 
28
+printf("%s", sys_errlist[0]);
 
29
   ;
 
30
   return 0;
 
31
 }
 
32
Index: b/w3mbookmark.c
 
33
===================================================================
 
34
--- a/w3mbookmark.c
 
35
+++ b/w3mbookmark.c
 
36
@@ -99,7 +99,7 @@
 
37
        fprintf(f, "<body>\n<h1>Bookmarks</h1>\n");
 
38
        fprintf(f, "<h2>%s</h2>\n<ul>\n", section);
 
39
        fprintf(f, "<li><a href=\"%s\">%s</a>\n", url, title);
 
40
-       fprintf(f, end_section);
 
41
+       fprintf(f, "%s", end_section);
 
42
        fprintf(f, "</ul>\n</body>\n</html>\n");
 
43
        fclose(f);
 
44
     }