~ubuntu-branches/ubuntu/breezy/ocamlgraph/breezy

« back to all changes in this revision

Viewing changes to debian/patches/01_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Sylvain Le Gall
  • Date: 2005-03-23 23:17:46 UTC
  • mfrom: (2.1.1 hoary)
  • Revision ID: james.westby@ubuntu.com-20050323231746-8rmzgp3zyslg4me5
Tags: 0.90-2
* Transition to ocaml 3.08.3 : depends on ocaml-nox-3.08.3
* Patch 03_META use graph.cma and graph.cmxa ( Closes: #294806 )
* Correct the patch 01_makefile to install graph.a ( Closes: #289138 )

Show diffs side-by-side

added added

removed removed

Lines of Context:
23
23
exit 0
24
24
 
25
25
@DPATCH@
26
 
diff -urNad /mnt/nfs0/gildor/deb/ocaml-package/TODO/ocamlgraph/ocamlgraph-0.6.1/Makefile.in ocamlgraph-0.6.1/Makefile.in
27
 
--- /mnt/nfs0/gildor/deb/ocaml-package/TODO/ocamlgraph/ocamlgraph-0.6.1/Makefile.in     2004-02-20 15:43:50.000000000 +0100
28
 
+++ ocamlgraph-0.6.1/Makefile.in        2004-02-22 23:29:48.000000000 +0100
29
 
@@ -135,17 +135,26 @@
 
26
diff -urNad ocamlgraph-0.90/Makefile.in /tmp/dpep.xPbub7/ocamlgraph-0.90/Makefile.in
 
27
--- ocamlgraph-0.90/Makefile.in 2004-12-03 02:18:47.000000000 +0100
 
28
+++ /tmp/dpep.xPbub7/ocamlgraph-0.90/Makefile.in        2004-12-03 02:21:38.000000000 +0100
 
29
@@ -132,15 +132,23 @@
30
30
 install: install-$(OCAMLBEST)
31
31
 
32
32
 install-byte: 
33
 
-       cp -f graph.cmi $(CMA) $(OCAMLLIB)
34
 
+       cp -f *.mli graph.cmi $(CMA) $(OCAMLLIB)
 
33
-       cp -f graph.cmo graph.cmi $(CMA) $(OCAMLLIB)
 
34
+       cp -f *.mli graph.cmo graph.cmi $(CMA) $(OCAMLLIB)
35
35
 
36
36
 install-opt: install-byte
37
 
-       cp -f $(CMXA) graph.o $(OCAMLLIB)
38
 
+       cp -f $(CMXA) graph.o $(OCAMLLIB)
 
37
        cp -f graph.a graph.cmx $(CMXA) $(OCAMLLIB)
39
38
 
40
39
-install-findlib: META
41
40
+install-findlib: install-findlib-$(OCAMLBEST)
43
42
+install-findlib-opt: META
44
43
 ifdef OCAMLFIND
45
44
-       $(OCAMLFIND) install ocamlgraph META *.mli \
46
 
-               graph.o graph.cmi $(CMA) $(CMXA)
 
45
-               graph.a graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
47
46
+       $(OCAMLFIND) install $(if $(DESTDIR),-destdir $(DESTDIR)) \
48
 
+               ocamlgraph META *.mli graph.o graph.cmi $(CMA) $(CMXA)
49
 
 endif
50
 
 
 
47
+               ocamlgraph META *.mli graph.a graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
 
48
+endif
 
49
51
50
+install-findlib-byte: META
52
51
+ifdef OCAMLFIND
53
52
+       $(OCAMLFIND) install $(if $(DESTDIR),-destdir $(DESTDIR)) \
54
 
+               ocamlgraph META *.mli graph.cmi $(CMA)
55
 
+endif
56
 
+
57
 
+
 
53
+               ocamlgraph META *.mli graph.cmi graph.cmo $(CMA)
 
54
 endif
 
55
 
58
56
 # documentation
59
 
 ###############
60