~ubuntu-branches/ubuntu/breezy/python-scipy/breezy

« back to all changes in this revision

Viewing changes to debian/patches/amd64.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alexandre Fayolle
  • Date: 2005-03-11 10:54:35 UTC
  • Revision ID: james.westby@ubuntu.com-20050311105435-li6q51e4cpcmw7ut
Tags: 0.3.2-6
Added a Suggests: python2.X-profiler in debian/control, made the
import of pstats optional by patching stats/__init__.py 
(Closes: #296796)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
 
 
3
# DP: Modified
 
4
 
 
5
if [ $# -ne 1 ]; then
 
6
    echo >&2 "$0: script expects -patch|-unpatch as argument"
 
7
    exit 1
 
8
fi
 
9
case "$1" in
 
10
    -patch) patch -f -p0 < $0;;
 
11
    -unpatch) patch -f -R -p0 < $0;;
 
12
    *)
 
13
        echo >&2 "$0: script expects -patch|-unpatch as argument"
 
14
        exit 1
 
15
esac
 
16
exit 0
 
17
 
 
18
 
 
19
--- Lib/stats/ranlib_all.c.orig 2004/08/27 16:31:44     1.2
 
20
+++ Lib/stats/ranlib_all.c      2005/01/04 16:21:16     1.3
 
21
@@ -2124,6 +2124,7 @@
 
22
     *iseed2 = *(Xcg2+g-1);
 
23
 #undef numg
 
24
 }
 
25
+static void inrgcm(void);
 
26
 long ignlgi(void)
 
27
 /*
 
28
 **********************************************************************
 
29
@@ -2146,7 +2147,6 @@
 
30
 extern long Xm1,Xm2,Xa1,Xa2,Xcg1[],Xcg2[];
 
31
 extern long Xqanti[];  
 
32
   */
 
33
-static void inrgcm(void);
 
34
 static long ignlgi,curntg,k,s1,s2,z;
 
35
 static long qqssd,qrgnin;
 
36
 /*