~ubuntu-branches/ubuntu/dapper/cyrus-sasl2/dapper-security

« back to all changes in this revision

Viewing changes to debian/patches/02_versioned_symbols.diff

  • Committer: Bazaar Package Importer
  • Author(s): Henrique de Moraes Holschuh
  • Date: 2004-10-08 13:06:28 UTC
  • Revision ID: james.westby@ubuntu.com-20041008130628-r437e5dm8j2rk4we
Tags: 2.1.19-1.3
* NMU
* Fix minor issue with -1.2 in patch 15, to squash a compiler
  warning (just in case it becomes more than a warning in some arch):
  add missing "int" to extern declaration

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nru3 ./cyrus-sasl-2.1.19/lib/Makefile.am ../build-tree.new/cyrus-sasl-2.1.19/lib/Makefile.am
 
2
--- ./cyrus-sasl-2.1.19/lib/Makefile.am 2004-07-02 20:39:36.000000000 +0100
 
3
+++ ../build-tree.new/cyrus-sasl-2.1.19/lib/Makefile.am 2004-07-17 19:07:03.000000000 +0100
 
4
@@ -60,8 +60,8 @@
 
5
 lib_LTLIBRARIES = libsasl2.la
 
6
 
 
7
 libsasl2_la_SOURCES = $(common_sources) $(common_headers)
 
8
-libsasl2_la_LDFLAGS = -version-info $(sasl_version)
 
9
-libsasl2_la_DEPENDENCIES = $(LTLIBOBJS)
 
10
+libsasl2_la_LDFLAGS = -version-info $(sasl_version) -Wl,--version-script=Versions
 
11
+libsasl2_la_DEPENDENCIES = $(LTLIBOBJS) Versions
 
12
 libsasl2_la_LIBADD = $(LTLIBOBJS) $(SASL_DL_LIB) $(LIB_SOCKET) $(LIB_DOOR)
 
13
 
 
14
 if MACOSX
 
15
@@ -92,3 +92,10 @@
 
16
        libsasl2.la >TMP.$$ && mv TMP.$$ libsasl2.la
 
17
        rm -f $@
 
18
        ln -s .libs/$@ $@
 
19
+
 
20
+Versions: $(libsasl2_la_OBJECTS)
 
21
+       rm -f $@
 
22
+       echo "SASL2 {" > $@
 
23
+       echo "  global:" >> $@
 
24
+       nm $(patsubst %.lo,%.o,$(libsasl2_la_OBJECTS)) | grep " [Tt] " | cut -d" " -f3 | sed -e 's/$$/;/' >>$@
 
25
+       echo "};" >> $@