~ubuntu-branches/ubuntu/dapper/cyrus-sasl2/dapper-updates

« back to all changes in this revision

Viewing changes to debian/patches/25_postgresql_pg_config.diff

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt, Adam Conrad
  • Date: 2006-04-10 11:46:53 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20060410114653-ze3gs0xfkofg7pqd
Tags: 2.1.19.dfsg1-0.1ubuntu1
* Synchronize to Debian (#28137)
* Reapply remaining Ubuntu changes to clean Debian package:
  - debian/patches/13_libdb42_autotools.diff, debian/control: Build against
    db4.3 instead of 4.2.
  - debian/control:  Since the libsasl2 package description so clearly states
    that the library is "completely useless" without one of the
    libsasl2-modules packages, upgrade the Recommends on a single package to
    an ORd Depends on the complete list of them. (Ubuntu bug #8046) 
    [Adam Conrad]

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nru3 ./cyrus-sasl-2.1.19.dfsg1/configure.in ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/configure.in
 
2
--- ./cyrus-sasl-2.1.19.dfsg1/configure.in      2006-01-07 06:04:03.000000000 -0800
 
3
+++ ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/configure.in      2006-01-07 06:03:53.000000000 -0800
 
4
@@ -701,14 +701,19 @@
 
5
      LIB_PGSQL_DIR=$LIB_PGSQL
 
6
      LIB_PGSQL="$LIB_PGSQL -lpq"
 
7
 
 
8
-     if test -d ${with_pgsql}/include/pgsql; then
 
9
-         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/include/pgsql"
 
10
-     elif test -d ${with_pgsql}/pgsql/include; then
 
11
-         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/pgsql/include"
 
12
+     if test -d ${with_pgsql}/include/pgsql/postgresql; then
 
13
+         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/include/pgsql/postgresql"
 
14
+     elif test -d ${with_pgsql}/pgsql/include/postgresql; then
 
15
+         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/pgsql/include/postgresql"
 
16
      elif test -d ${with_pgsql}/include; then
 
17
-         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/include"
 
18
+         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/include/postgresql"
 
19
      else
 
20
-         CPPFLAGS="${CPPFLAGS} -I${with_pgsql}"
 
21
+         pg_config_flags=$(pg_config --includedir)
 
22
+        if test x"$pg_config_flags" != x; then
 
23
+             CPPFLAGS="${CPPFLAGS} -I$pg_config_flags"
 
24
+         else
 
25
+             CPPFLAGS="${CPPFLAGS} -I${with_pgsql}/postgresql"
 
26
+         fi
 
27
      fi
 
28
 
 
29
 
 
30
diff -Nru3 ./cyrus-sasl-2.1.19.dfsg1/plugins/sql.c ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/plugins/sql.c
 
31
--- ./cyrus-sasl-2.1.19.dfsg1/plugins/sql.c     2006-01-07 06:04:02.000000000 -0800
 
32
+++ ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/plugins/sql.c     2006-01-07 05:51:20.000000000 -0800
 
33
@@ -180,7 +180,7 @@
 
34
 #endif /* HAVE_MYSQL */
 
35
 
 
36
 #ifdef HAVE_PGSQL
 
37
-#include <postgresql/libpq-fe.h>
 
38
+#include <libpq-fe.h>
 
39
 
 
40
 static void *_pgsql_open(char *host, char *port, int usessl,
 
41
                         const char *user, const char *password,