~ubuntu-branches/ubuntu/dapper/freeradius/dapper-updates

« back to all changes in this revision

Viewing changes to debian/patches/02_EAP-SIM_doesnt_need_openssl.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Hampson
  • Date: 2005-06-27 03:13:48 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20050627031348-tu393q64vdle45ah
Tags: 1.0.4-2
* Fix my email address in the dpatches
* Remove extraneous ^g from man/man5/clients.conf.5
  - Created 04_bonus_control_code_in_clients_conf_5
* Correct handing of parameterless call of init script, and
  general init script neatening
  (Thanks to Derrick Karpo)
  Closes: #315438
* Correctly leave out the .in files in the examples
* Correctly use debhelper after splitting binary make target
  into binary-arch and binary-indep.
  (Thanks to Kurt Roeckx for actually hitting the bug)
  Closes: #315770
* Steal fix from CVS release_1_0 tree for rlm_sql quoted values.
  (Thanks to Nicolas Baradakis for the fix)
  - Upstream bugzilla #242, src/modules/rlm_sql/sql.c 1.79.2.2
  - Created 05_unbreak_quoted_sql_values

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02_EAP-SIM_doesnt_need_openssl.dpatch by  <Paul.Hampson@anu.edu.au>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: EAP-SIM does not require openssl to build
 
6
 
 
7
@DPATCH@
 
8
 
 
9
--- freeradius-1.0.2.orig/src/modules/rlm_eap/types/rlm_eap_sim/configure
 
10
+++ freeradius-1.0.2/src/modules/rlm_eap/types/rlm_eap_sim/configure
 
11
@@ -11,10 +11,6 @@
 
12
 ac_help=
 
13
 ac_default_prefix=/usr/local
 
14
 # Any additions from configure.in:
 
15
-ac_help="$ac_help
 
16
-  --with-openssl-includes=DIR       Directory to look for OpenSSL include files"
 
17
-ac_help="$ac_help
 
18
-  --with-openssl-libraries=DIR      Directory to look for OpenSSL library files"
 
19
 
 
20
 # Initialize some variables set by options.
 
21
 # The variables have the same names as the options, with
 
22
@@ -536,7 +532,7 @@
 
23
        # Extract the first word of "gcc", so it can be a program name with args.
 
24
 set dummy gcc; ac_word=$2
 
25
 echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
 
26
-echo "configure:540: checking for $ac_word" >&5
 
27
+echo "configure:536: checking for $ac_word" >&5
 
28
 if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
 
29
   echo $ac_n "(cached) $ac_c" 1>&6
 
30
 else
 
31
@@ -566,7 +562,7 @@
 
32
   # Extract the first word of "cc", so it can be a program name with args.
 
33
 set dummy cc; ac_word=$2
 
34
 echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
 
35
-echo "configure:570: checking for $ac_word" >&5
 
36
+echo "configure:566: checking for $ac_word" >&5
 
37
 if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
 
38
   echo $ac_n "(cached) $ac_c" 1>&6
 
39
 else
 
40
@@ -617,7 +613,7 @@
 
41
       # Extract the first word of "cl", so it can be a program name with args.
 
42
 set dummy cl; ac_word=$2
 
43
 echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
 
44
-echo "configure:621: checking for $ac_word" >&5
 
45
+echo "configure:617: checking for $ac_word" >&5
 
46
 if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
 
47
   echo $ac_n "(cached) $ac_c" 1>&6
 
48
 else
 
49
@@ -649,7 +645,7 @@
 
50
 fi
 
51
 
 
52
 echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works""... $ac_c" 1>&6
 
53
-echo "configure:653: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
 
54
+echo "configure:649: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) works" >&5
 
55
 
 
56
 ac_ext=c
 
57
 # CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
 
58
@@ -660,12 +656,12 @@
 
59
 
 
60
 cat > conftest.$ac_ext << EOF
 
61
 
 
62
-#line 664 "configure"
 
63
+#line 660 "configure"
 
64
 #include "confdefs.h"
 
65
 
 
66
 main(){return(0);}
 
67
 EOF
 
68
-if { (eval echo configure:669: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
69
+if { (eval echo configure:665: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
70
   ac_cv_prog_cc_works=yes
 
71
   # If we can't run a trivial program, we are probably using a cross compiler.
 
72
   if (./conftest; exit) 2>/dev/null; then
 
73
@@ -691,12 +687,12 @@
 
74
   { echo "configure: error: installation or configuration problem: C compiler cannot create executables." 1>&2; exit 1; }
 
75
 fi
 
76
 echo $ac_n "checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
 
77
-echo "configure:695: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
 
78
+echo "configure:691: checking whether the C compiler ($CC $CFLAGS $LDFLAGS) is a cross-compiler" >&5
 
79
 echo "$ac_t""$ac_cv_prog_cc_cross" 1>&6
 
80
 cross_compiling=$ac_cv_prog_cc_cross
 
81
 
 
82
 echo $ac_n "checking whether we are using GNU C""... $ac_c" 1>&6
 
83
-echo "configure:700: checking whether we are using GNU C" >&5
 
84
+echo "configure:696: checking whether we are using GNU C" >&5
 
85
 if eval "test \"`echo '$''{'ac_cv_prog_gcc'+set}'`\" = set"; then
 
86
   echo $ac_n "(cached) $ac_c" 1>&6
 
87
 else
 
88
@@ -705,7 +701,7 @@
 
89
   yes;
 
90
 #endif
 
91
 EOF
 
92
-if { ac_try='${CC-cc} -E conftest.c'; { (eval echo configure:709: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; } | egrep yes >/dev/null 2>&1; then
 
93
+if { ac_try='${CC-cc} -E conftest.c'; { (eval echo configure:705: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }; } | egrep yes >/dev/null 2>&1; then
 
94
   ac_cv_prog_gcc=yes
 
95
 else
 
96
   ac_cv_prog_gcc=no
 
97
@@ -724,7 +720,7 @@
 
98
 ac_save_CFLAGS="$CFLAGS"
 
99
 CFLAGS=
 
100
 echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
 
101
-echo "configure:728: checking whether ${CC-cc} accepts -g" >&5
 
102
+echo "configure:724: checking whether ${CC-cc} accepts -g" >&5
 
103
 if eval "test \"`echo '$''{'ac_cv_prog_cc_g'+set}'`\" = set"; then
 
104
   echo $ac_n "(cached) $ac_c" 1>&6
 
105
 else
 
106
@@ -756,508 +752,6 @@
 
107
 fi
 
108
 
 
109
 
 
110
-                               # Check whether --with-openssl-includes or --without-openssl-includes was given.
 
111
-if test "${with_openssl_includes+set}" = set; then
 
112
-  withval="$with_openssl_includes"
 
113
-   case "$withval" in
 
114
-           *)
 
115
-               rlm_eap_peap_inc_dir="$rlm_eap_peap_inc_dir $withval"
 
116
-               SMART_CFLAGS="$SMART_CFLAGS -I$withval"
 
117
-               ;;
 
118
-         esac 
 
119
-       
 
120
-fi
 
121
-
 
122
-
 
123
-                               # Check whether --with-openssl-libraries or --without-openssl-libraries was given.
 
124
-if test "${with_openssl_libraries+set}" = set; then
 
125
-  withval="$with_openssl_libraries"
 
126
-   case "$withval" in
 
127
-           *)
 
128
-               rlm_eap_peap_lib_dir="$rlm_eap_peap_lib_dir $withval"
 
129
-               SMART_LIBS="$SMART_LIBS -L$withval"
 
130
-               ;;
 
131
-         esac 
 
132
-       
 
133
-fi
 
134
-
 
135
-
 
136
-       smart_try_dir=$rlm_eap_peap_inc_dir
 
137
-       
 
138
-
 
139
-ac_safe=`echo "openssl/ssl.h" | sed 'y%./+-%__pm%'`
 
140
-echo $ac_n "checking for openssl/ssl.h""... $ac_c" 1>&6
 
141
-echo "configure:791: checking for openssl/ssl.h" >&5
 
142
-
 
143
-smart_include=
 
144
-smart_include_dir=
 
145
-
 
146
-  old_CFLAGS="$CFLAGS"
 
147
-  cat > conftest.$ac_ext <<EOF
 
148
-#line 798 "configure"
 
149
-#include "confdefs.h"
 
150
-
 
151
-                 #include <openssl/ssl.h>
 
152
-int main() {
 
153
- int a = 1;
 
154
-; return 0; }
 
155
-EOF
 
156
-if { (eval echo configure:806: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
 
157
-  rm -rf conftest*
 
158
-  smart_include=" "
 
159
-else
 
160
-  echo "configure: failed program was:" >&5
 
161
-  cat conftest.$ac_ext >&5
 
162
-  rm -rf conftest*
 
163
-  smart_include=
 
164
-fi
 
165
-rm -f conftest*
 
166
-
 
167
-  if test "x$smart_include" = "x"; then
 
168
-    
 
169
-
 
170
-if test "x$LOCATE" != "x"; then
 
171
-        DIRS=
 
172
-  file=openssl/ssl.h
 
173
-
 
174
-  for x in `${LOCATE} $file 2>/dev/null`; do
 
175
-                                        base=`echo $x | sed "s%/${file}%%"`
 
176
-    if test "x$x" = "x$base"; then
 
177
-      continue;
 
178
-    fi
 
179
-
 
180
-    dir=`${DIRNAME} $x 2>/dev/null`
 
181
-                exclude=`echo ${dir} | ${GREP} /home`
 
182
-    if test "x$exclude" != "x"; then
 
183
-      continue
 
184
-    fi
 
185
-
 
186
-                    already=`echo \$smart_include_dir ${DIRS} | ${GREP} ${dir}`
 
187
-    if test "x$already" = "x"; then
 
188
-      DIRS="$DIRS $dir"
 
189
-    fi
 
190
-  done
 
191
-fi
 
192
-
 
193
-eval "smart_include_dir=\"\$smart_include_dir $DIRS\""
 
194
-
 
195
-
 
196
-    for try in $smart_try_dir $smart_include_dir /usr/local/include/ /opt/include; do
 
197
-      CFLAGS="$old_CFLAGS -I$try"
 
198
-
 
199
-      cat > conftest.$ac_ext <<EOF
 
200
-#line 850 "configure"
 
201
-#include "confdefs.h"
 
202
-
 
203
-                      #include <openssl/ssl.h>
 
204
-int main() {
 
205
- int a = 1;
 
206
-; return 0; }
 
207
-EOF
 
208
-if { (eval echo configure:858: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
 
209
-  rm -rf conftest*
 
210
-  smart_include="-I$try"
 
211
-else
 
212
-  echo "configure: failed program was:" >&5
 
213
-  cat conftest.$ac_ext >&5
 
214
-  rm -rf conftest*
 
215
-  smart_include=
 
216
-fi
 
217
-rm -f conftest*
 
218
-
 
219
-      if test "x$smart_include" != "x"; then
 
220
-        break;
 
221
-      fi
 
222
-    done
 
223
-    CFLAGS="$old_CFLAGS"
 
224
-  fi
 
225
-
 
226
-        if test "x$smart_include" != "x"; then
 
227
-    echo "$ac_t""yes" 1>&6
 
228
-    eval "ac_cv_header_$ac_safe=yes"
 
229
-    CFLAGS="$old_CFLAGS $smart_include"
 
230
-    SMART_CFLAGS="$SMART_CFLAGS $smart_include"
 
231
-  else
 
232
-    echo "$ac_t""no" 1>&6 
 
233
-fi
 
234
-
 
235
-       if test "x$ac_cv_header_openssl_ssl_h" != "xyes"; then
 
236
-               fail="$fail (openssl/ssl.h)"
 
237
-       fi
 
238
-
 
239
-       smart_try_dir=$rlm_eap_peap_lib_dir
 
240
-       
 
241
-
 
242
-sm_lib_safe=`echo "crypto" | sed 'y%./+-%__p_%'`
 
243
-sm_func_safe=`echo "DH_new" | sed 'y%./+-%__p_%'`
 
244
-echo $ac_n "checking for DH_new in -lcrypto""... $ac_c" 1>&6
 
245
-echo "configure:895: checking for DH_new in -lcrypto" >&5
 
246
-
 
247
-smart_lib=
 
248
-smart_lib_dir=
 
249
-
 
250
-  old_LIBS="$LIBS"
 
251
-  LIBS="$LIBS -lcrypto"
 
252
-  cat > conftest.$ac_ext <<EOF
 
253
-#line 903 "configure"
 
254
-#include "confdefs.h"
 
255
-extern char DH_new();
 
256
-int main() {
 
257
- DH_new()
 
258
-; return 0; }
 
259
-EOF
 
260
-if { (eval echo configure:910: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
261
-  rm -rf conftest*
 
262
-  smart_lib="-lcrypto"
 
263
-else
 
264
-  echo "configure: failed program was:" >&5
 
265
-  cat conftest.$ac_ext >&5
 
266
-fi
 
267
-rm -f conftest*
 
268
-
 
269
-  if test "x$smart_lib" = "x"; then
 
270
-    
 
271
-
 
272
-if test "x$LOCATE" != "x"; then
 
273
-        DIRS=
 
274
-  file=libcrypto${libltdl_cv_shlibext}
 
275
-
 
276
-  for x in `${LOCATE} $file 2>/dev/null`; do
 
277
-                                        base=`echo $x | sed "s%/${file}%%"`
 
278
-    if test "x$x" = "x$base"; then
 
279
-      continue;
 
280
-    fi
 
281
-
 
282
-    dir=`${DIRNAME} $x 2>/dev/null`
 
283
-                exclude=`echo ${dir} | ${GREP} /home`
 
284
-    if test "x$exclude" != "x"; then
 
285
-      continue
 
286
-    fi
 
287
-
 
288
-                    already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
 
289
-    if test "x$already" = "x"; then
 
290
-      DIRS="$DIRS $dir"
 
291
-    fi
 
292
-  done
 
293
-fi
 
294
-
 
295
-eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
 
296
-
 
297
-    
 
298
-
 
299
-if test "x$LOCATE" != "x"; then
 
300
-        DIRS=
 
301
-  file=libcrypto.a
 
302
-
 
303
-  for x in `${LOCATE} $file 2>/dev/null`; do
 
304
-                                        base=`echo $x | sed "s%/${file}%%"`
 
305
-    if test "x$x" = "x$base"; then
 
306
-      continue;
 
307
-    fi
 
308
-
 
309
-    dir=`${DIRNAME} $x 2>/dev/null`
 
310
-                exclude=`echo ${dir} | ${GREP} /home`
 
311
-    if test "x$exclude" != "x"; then
 
312
-      continue
 
313
-    fi
 
314
-
 
315
-                    already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
 
316
-    if test "x$already" = "x"; then
 
317
-      DIRS="$DIRS $dir"
 
318
-    fi
 
319
-  done
 
320
-fi
 
321
-
 
322
-eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
 
323
-
 
324
-
 
325
-    for try in $smart_try_dir $smart_lib_dir /usr/local/lib/ /opt/lib; do
 
326
-      LIBS="$old_LIBS -L$try -lcrypto"
 
327
-
 
328
-      cat > conftest.$ac_ext <<EOF
 
329
-#line 979 "configure"
 
330
-#include "confdefs.h"
 
331
-extern char DH_new();
 
332
-int main() {
 
333
- DH_new()
 
334
-; return 0; }
 
335
-EOF
 
336
-if { (eval echo configure:986: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
337
-  rm -rf conftest*
 
338
-  smart_lib="-L$try -lcrypto"
 
339
-else
 
340
-  echo "configure: failed program was:" >&5
 
341
-  cat conftest.$ac_ext >&5
 
342
-fi
 
343
-rm -f conftest*
 
344
-      if test "x$smart_lib" != "x"; then
 
345
-        break;
 
346
-      fi
 
347
-    done
 
348
-    LIBS="$old_LIBS"
 
349
-  fi
 
350
-
 
351
-        if test "x$smart_lib" != "x"; then
 
352
-    echo "$ac_t""yes" 1>&6
 
353
-    eval "ac_cv_lib_${sm_lib_safe}_${sm_func_safe}=yes"
 
354
-    LIBS="$old_LIBS $smart_lib"
 
355
-    SMART_LIBS="$SMART_LIBS $smart_lib"
 
356
-  else
 
357
-    echo "$ac_t""no" 1>&6 
 
358
-fi
 
359
-
 
360
-    if test "x$ac_cv_lib_crypto_DH_new" != "xyes"; then
 
361
-           fail="$fail libcrypto"
 
362
-    fi
 
363
-
 
364
-       
 
365
-
 
366
-sm_lib_safe=`echo "ssl" | sed 'y%./+-%__p_%'`
 
367
-sm_func_safe=`echo "SSL_new" | sed 'y%./+-%__p_%'`
 
368
-echo $ac_n "checking for SSL_new in -lssl""... $ac_c" 1>&6
 
369
-echo "configure:1019: checking for SSL_new in -lssl" >&5
 
370
-
 
371
-smart_lib=
 
372
-smart_lib_dir=
 
373
-
 
374
-  old_LIBS="$LIBS"
 
375
-  LIBS="$LIBS -lssl"
 
376
-  cat > conftest.$ac_ext <<EOF
 
377
-#line 1027 "configure"
 
378
-#include "confdefs.h"
 
379
-extern char SSL_new();
 
380
-int main() {
 
381
- SSL_new()
 
382
-; return 0; }
 
383
-EOF
 
384
-if { (eval echo configure:1034: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
385
-  rm -rf conftest*
 
386
-  smart_lib="-lssl"
 
387
-else
 
388
-  echo "configure: failed program was:" >&5
 
389
-  cat conftest.$ac_ext >&5
 
390
-fi
 
391
-rm -f conftest*
 
392
-
 
393
-  if test "x$smart_lib" = "x"; then
 
394
-    
 
395
-
 
396
-if test "x$LOCATE" != "x"; then
 
397
-        DIRS=
 
398
-  file=libssl${libltdl_cv_shlibext}
 
399
-
 
400
-  for x in `${LOCATE} $file 2>/dev/null`; do
 
401
-                                        base=`echo $x | sed "s%/${file}%%"`
 
402
-    if test "x$x" = "x$base"; then
 
403
-      continue;
 
404
-    fi
 
405
-
 
406
-    dir=`${DIRNAME} $x 2>/dev/null`
 
407
-                exclude=`echo ${dir} | ${GREP} /home`
 
408
-    if test "x$exclude" != "x"; then
 
409
-      continue
 
410
-    fi
 
411
-
 
412
-                    already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
 
413
-    if test "x$already" = "x"; then
 
414
-      DIRS="$DIRS $dir"
 
415
-    fi
 
416
-  done
 
417
-fi
 
418
-
 
419
-eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
 
420
-
 
421
-    
 
422
-
 
423
-if test "x$LOCATE" != "x"; then
 
424
-        DIRS=
 
425
-  file=libssl.a
 
426
-
 
427
-  for x in `${LOCATE} $file 2>/dev/null`; do
 
428
-                                        base=`echo $x | sed "s%/${file}%%"`
 
429
-    if test "x$x" = "x$base"; then
 
430
-      continue;
 
431
-    fi
 
432
-
 
433
-    dir=`${DIRNAME} $x 2>/dev/null`
 
434
-                exclude=`echo ${dir} | ${GREP} /home`
 
435
-    if test "x$exclude" != "x"; then
 
436
-      continue
 
437
-    fi
 
438
-
 
439
-                    already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
 
440
-    if test "x$already" = "x"; then
 
441
-      DIRS="$DIRS $dir"
 
442
-    fi
 
443
-  done
 
444
-fi
 
445
-
 
446
-eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
 
447
-
 
448
-
 
449
-    for try in $smart_try_dir $smart_lib_dir /usr/local/lib/ /opt/lib; do
 
450
-      LIBS="$old_LIBS -L$try -lssl"
 
451
-
 
452
-      cat > conftest.$ac_ext <<EOF
 
453
-#line 1103 "configure"
 
454
-#include "confdefs.h"
 
455
-extern char SSL_new();
 
456
-int main() {
 
457
- SSL_new()
 
458
-; return 0; }
 
459
-EOF
 
460
-if { (eval echo configure:1110: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
 
461
-  rm -rf conftest*
 
462
-  smart_lib="-L$try -lssl"
 
463
-else
 
464
-  echo "configure: failed program was:" >&5
 
465
-  cat conftest.$ac_ext >&5
 
466
-fi
 
467
-rm -f conftest*
 
468
-      if test "x$smart_lib" != "x"; then
 
469
-        break;
 
470
-      fi
 
471
-    done
 
472
-    LIBS="$old_LIBS"
 
473
-  fi
 
474
-
 
475
-        if test "x$smart_lib" != "x"; then
 
476
-    echo "$ac_t""yes" 1>&6
 
477
-    eval "ac_cv_lib_${sm_lib_safe}_${sm_func_safe}=yes"
 
478
-    LIBS="$old_LIBS $smart_lib"
 
479
-    SMART_LIBS="$SMART_LIBS $smart_lib"
 
480
-  else
 
481
-    echo "$ac_t""no" 1>&6 
 
482
-fi
 
483
-
 
484
-    if test "x$ac_cv_lib_ssl_SSL_new" != "xyes"; then
 
485
-           fail="$fail libssl"
 
486
-    fi
 
487
-
 
488
-       echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
 
489
-echo "configure:1139: checking how to run the C preprocessor" >&5
 
490
-# On Suns, sometimes $CPP names a directory.
 
491
-if test -n "$CPP" && test -d "$CPP"; then
 
492
-  CPP=
 
493
-fi
 
494
-if test -z "$CPP"; then
 
495
-if eval "test \"`echo '$''{'ac_cv_prog_CPP'+set}'`\" = set"; then
 
496
-  echo $ac_n "(cached) $ac_c" 1>&6
 
497
-else
 
498
-    # This must be in double quotes, not single quotes, because CPP may get
 
499
-  # substituted into the Makefile and "${CC-cc}" will confuse make.
 
500
-  CPP="${CC-cc} -E"
 
501
-  # On the NeXT, cc -E runs the code through the compiler's parser,
 
502
-  # not just through cpp.
 
503
-  cat > conftest.$ac_ext <<EOF
 
504
-#line 1154 "configure"
 
505
-#include "confdefs.h"
 
506
-#include <assert.h>
 
507
-Syntax Error
 
508
-EOF
 
509
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
 
510
-{ (eval echo configure:1160: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
 
511
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
 
512
-if test -z "$ac_err"; then
 
513
-  :
 
514
-else
 
515
-  echo "$ac_err" >&5
 
516
-  echo "configure: failed program was:" >&5
 
517
-  cat conftest.$ac_ext >&5
 
518
-  rm -rf conftest*
 
519
-  CPP="${CC-cc} -E -traditional-cpp"
 
520
-  cat > conftest.$ac_ext <<EOF
 
521
-#line 1171 "configure"
 
522
-#include "confdefs.h"
 
523
-#include <assert.h>
 
524
-Syntax Error
 
525
-EOF
 
526
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
 
527
-{ (eval echo configure:1177: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
 
528
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
 
529
-if test -z "$ac_err"; then
 
530
-  :
 
531
-else
 
532
-  echo "$ac_err" >&5
 
533
-  echo "configure: failed program was:" >&5
 
534
-  cat conftest.$ac_ext >&5
 
535
-  rm -rf conftest*
 
536
-  CPP="${CC-cc} -nologo -E"
 
537
-  cat > conftest.$ac_ext <<EOF
 
538
-#line 1188 "configure"
 
539
-#include "confdefs.h"
 
540
-#include <assert.h>
 
541
-Syntax Error
 
542
-EOF
 
543
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
 
544
-{ (eval echo configure:1194: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
 
545
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
 
546
-if test -z "$ac_err"; then
 
547
-  :
 
548
-else
 
549
-  echo "$ac_err" >&5
 
550
-  echo "configure: failed program was:" >&5
 
551
-  cat conftest.$ac_ext >&5
 
552
-  rm -rf conftest*
 
553
-  CPP=/lib/cpp
 
554
-fi
 
555
-rm -f conftest*
 
556
-fi
 
557
-rm -f conftest*
 
558
-fi
 
559
-rm -f conftest*
 
560
-  ac_cv_prog_CPP="$CPP"
 
561
-fi
 
562
-  CPP="$ac_cv_prog_CPP"
 
563
-else
 
564
-  ac_cv_prog_CPP="$CPP"
 
565
-fi
 
566
-echo "$ac_t""$CPP" 1>&6
 
567
-
 
568
-for ac_hdr in \
 
569
-               openssl/err.h \
 
570
-               openssl/engine.h \
 
571
-       
 
572
-do
 
573
-ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
 
574
-echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
 
575
-echo "configure:1225: checking for $ac_hdr" >&5
 
576
-if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
 
577
-  echo $ac_n "(cached) $ac_c" 1>&6
 
578
-else
 
579
-  cat > conftest.$ac_ext <<EOF
 
580
-#line 1230 "configure"
 
581
-#include "confdefs.h"
 
582
-#include <$ac_hdr>
 
583
-EOF
 
584
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
 
585
-{ (eval echo configure:1235: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
 
586
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
 
587
-if test -z "$ac_err"; then
 
588
-  rm -rf conftest*
 
589
-  eval "ac_cv_header_$ac_safe=yes"
 
590
-else
 
591
-  echo "$ac_err" >&5
 
592
-  echo "configure: failed program was:" >&5
 
593
-  cat conftest.$ac_ext >&5
 
594
-  rm -rf conftest*
 
595
-  eval "ac_cv_header_$ac_safe=no"
 
596
-fi
 
597
-rm -f conftest*
 
598
-fi
 
599
-if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
 
600
-  echo "$ac_t""yes" 1>&6
 
601
-    ac_tr_hdr=HAVE_`echo $ac_hdr | sed 'y%abcdefghijklmnopqrstuvwxyz./-%ABCDEFGHIJKLMNOPQRSTUVWXYZ___%'`
 
602
-  cat >> confdefs.h <<EOF
 
603
-#define $ac_tr_hdr 1
 
604
-EOF
 
605
 
606
-else
 
607
-  echo "$ac_t""no" 1>&6
 
608
-fi
 
609
-done
 
610
-
 
611
-
 
612
        targetname=rlm_eap_sim
 
613
 else
 
614
        targetname=
 
615
@@ -1419,7 +913,6 @@
 
616
 s%@infodir@%$infodir%g
 
617
 s%@mandir@%$mandir%g
 
618
 s%@CC@%$CC%g
 
619
-s%@CPP@%$CPP%g
 
620
 s%@eap_sim_ldflags@%$eap_sim_ldflags%g
 
621
 s%@eap_sim_cflags@%$eap_sim_cflags%g
 
622
 s%@targetname@%$targetname%g
 
623
--- freeradius-1.0.2.orig/src/modules/rlm_eap/types/rlm_eap_sim/configure.in
 
624
+++ freeradius-1.0.2/src/modules/rlm_eap/types/rlm_eap_sim/configure.in
 
625
@@ -9,54 +9,6 @@
 
626
 
 
627
        AC_PROG_CC
 
628
 
 
629
-       dnl #
 
630
-       dnl # extra argument: --openssl-includes=dir
 
631
-       dnl #
 
632
-       AC_ARG_WITH(openssl-includes,
 
633
-       [  --with-openssl-includes=DIR       Directory to look for OpenSSL include files],
 
634
-       [ case "$withval" in
 
635
-           *)
 
636
-               rlm_eap_peap_inc_dir="$rlm_eap_peap_inc_dir $withval"
 
637
-               SMART_CFLAGS="$SMART_CFLAGS -I$withval"
 
638
-               ;;
 
639
-         esac ]
 
640
-       )
 
641
-
 
642
-       dnl #
 
643
-       dnl # extra argument: --openssl-libraries=dir
 
644
-       dnl #
 
645
-       AC_ARG_WITH(openssl-libraries,
 
646
-       [  --with-openssl-libraries=DIR      Directory to look for OpenSSL library files],
 
647
-       [ case "$withval" in
 
648
-           *)
 
649
-               rlm_eap_peap_lib_dir="$rlm_eap_peap_lib_dir $withval"
 
650
-               SMART_LIBS="$SMART_LIBS -L$withval"
 
651
-               ;;
 
652
-         esac ]
 
653
-       )
 
654
-
 
655
-       smart_try_dir=$rlm_eap_peap_inc_dir
 
656
-       AC_SMART_CHECK_INCLUDE(openssl/ssl.h)
 
657
-       if test "x$ac_cv_header_openssl_ssl_h" != "xyes"; then
 
658
-               fail="$fail (openssl/ssl.h)"
 
659
-       fi
 
660
-
 
661
-       smart_try_dir=$rlm_eap_peap_lib_dir
 
662
-       AC_SMART_CHECK_LIB(crypto, DH_new)
 
663
-    if test "x$ac_cv_lib_crypto_DH_new" != "xyes"; then
 
664
-           fail="$fail libcrypto"
 
665
-    fi
 
666
-
 
667
-       AC_SMART_CHECK_LIB(ssl, SSL_new)
 
668
-    if test "x$ac_cv_lib_ssl_SSL_new" != "xyes"; then
 
669
-           fail="$fail libssl"
 
670
-    fi
 
671
-
 
672
-       AC_CHECK_HEADERS( \
 
673
-               openssl/err.h \
 
674
-               openssl/engine.h \
 
675
-       )
 
676
-
 
677
        targetname=modname
 
678
 else
 
679
        targetname=