~ubuntu-branches/ubuntu/feisty/bmagic/feisty

« back to all changes in this revision

Viewing changes to debian/patches/amd64.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Wes Chow
  • Date: 2006-10-17 10:36:56 UTC
  • Revision ID: james.westby@ubuntu.com-20061017103656-xkwuz8sbtbzikm0s
Tags: 3.4.0-4
Fix amd64 patch so that it works correctly with debuild
cleans. (Closes: #382981)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## amd64.dpatch by  <wchow@athenacr.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fixes build on AMD64 system.  Thanks goes to Andreas Jochens.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad bmagic-3.4.0~/canon-system bmagic-3.4.0/canon-system
 
9
--- bmagic-3.4.0~/canon-system  2003-03-27 19:42:44.000000000 -0500
 
10
+++ bmagic-3.4.0/canon-system   2006-08-17 12:29:16.000000000 -0400
 
11
@@ -30,7 +30,7 @@
 
12
        echo intel-unixware7
 
13
        exit 0;;
 
14
 
 
15
-   i[34567]86-*-linux-gnu*)
 
16
+   i[34567]86-*-linux-gnu*|x86_64-*-linux-gnu*)
 
17
        echo intel-linux-gnu
 
18
        exit 0;;
 
19
 
 
20
diff -urNad bmagic-3.4.0~/platforms/intel-linux-gnu.mk bmagic-3.4.0/platforms/intel-linux-gnu.mk
 
21
--- bmagic-3.4.0~/platforms/intel-linux-gnu.mk  2004-05-14 19:52:00.000000000 -0400
 
22
+++ bmagic-3.4.0/platforms/intel-linux-gnu.mk   2006-08-17 12:29:16.000000000 -0400
 
23
@@ -10,8 +10,8 @@
 
24
     COMMON_LDFLAGS = $(LINKER_DFLAGS) -export-dynamic
 
25
     COMMON_CLDFLAGS = $(COMMON_LDFLAGS)
 
26
     EXTERN_LIBS = $(EXTERN_LIBS_BASE)/lib
 
27
-    CXX = g++ -mcpu=pentiumpro -march=pentiumpro -Wall 
 
28
-    CC = gcc -mcpu=pentiumpro -march=pentiumpro -Wall 
 
29
+    CXX = g++ -Wall 
 
30
+    CC = gcc -Wall 
 
31
     LD = g++
 
32
     CC_PIC_FLAGS = -fPIC
 
33
     CXX_PIC_FLAGS = -fPIC