~ubuntu-branches/ubuntu/feisty/fontforge/feisty

« back to all changes in this revision

Viewing changes to debian/patches/009_fix_SVG_output_quotes.diff

  • Committer: Bazaar Package Importer
  • Author(s): Kęstutis BiliÅ«nas
  • Date: 2006-10-23 15:24:15 UTC
  • mfrom: (1.1.5 upstream) (2.1.1 etch)
  • Revision ID: james.westby@ubuntu.com-20061023152415-tde4mufot043kno2
Tags: 0.0.20061019-1
* New upstream release (Closes: #394675).
* debian/patches:
  - removed the patch 008_nohomedir.diff -- fixed upstream.
  - added patch 009_fix_SVG_output_quotes.diff for fixing missing quotes in
    SVG output (Closes: #392688). Thanks to Wojciech Muła <wm@mahajana.net>.
* debian/control: added the version number to Recommends for
  libuninameslist0 package.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Fix the missing quotes in SVG output (Bug#392688).
 
2
 
 
3
This patch by Wojciech Muła <wm@mahajana.net>.
 
4
This patch will be removed on the next upstream release.
 
5
 
 
6
Index: fontforge/fontforge/svg.c
 
7
===================================================================
 
8
--- fontforge/fontforge/svg.c.orig      2006-10-24 08:58:11.000000000 +0300
 
9
+++ fontforge/fontforge/svg.c   2006-10-24 09:07:32.000000000 +0300
 
10
@@ -103,7 +103,7 @@
 
11
     else if ( MacStyleCode(sf,NULL)&sf_italic )
 
12
        fprintf( file, "    font-style=\"italic\"\n" );
 
13
     if ( strstrmatch(sf->fontname,"small") || strstrmatch(sf->fontname,"cap") )
 
14
-       fprintf( file, "    font-variant=small-caps\n" );
 
15
+       fprintf( file, "    font-variant=\"small-caps\"\n" );
 
16
     fprintf( file, "    font-stretch=\"%s\"\n", condexp[info.width]);
 
17
     fprintf( file, "    units-per-em=\"%d\"\n", sf->ascent+sf->descent );
 
18
     fprintf( file, "    panose-1=\"%d %d %d %d %d %d %d %d %d %d\"\n", info.panose[0],
 
19
@@ -490,13 +490,13 @@
 
20
        fprintf( file, "orientation=\"v\" " );
 
21
     if ( encuni!=-1 && encuni<0x10000 ) {
 
22
        if ( isarabinitial(encuni))
 
23
-           fprintf( file,"arabic-form=initial " );
 
24
+           fprintf( file,"arabic-form=\"initial\" " );
 
25
        else if ( isarabmedial(encuni))
 
26
-           fprintf( file,"arabic-form=medial ");
 
27
+           fprintf( file,"arabic-form=\"medial\" ");
 
28
        else if ( isarabfinal(encuni))
 
29
-           fprintf( file,"arabic-form=final ");
 
30
+           fprintf( file,"arabic-form=\"final\" ");
 
31
        else if ( isarabisolated(encuni))
 
32
-           fprintf( file,"arabic-form=isolated ");
 
33
+           fprintf( file,"arabic-form=\"isolated\" ");
 
34
     }
 
35
     putc('\n',file);
 
36
     svg_scpathdump(file,sc," </glyph>\n");