~ubuntu-branches/ubuntu/feisty/freeradius/feisty-security

« back to all changes in this revision

Viewing changes to debian/patches/01-fix-proxy.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stephen Gran, Stephen Gran, Mark Hymers
  • Date: 2006-10-07 21:08:35 UTC
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20061007210835-b1j9k0ua14ylaqvg
Tags: 1.1.3-2
[ Stephen Gran ]
* Check for existence of pidfile in initscript.
* Clean some old cruft from debian/rules
* Write dialup_admin/Makefile
* Make binNMU safe
* Some lsb init headers

[ Mark Hymers ]
* Merge upstream patch to deal with proxy port settings.  Closes: #388024.
* Rewrite large parts of the Debian build system.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01_fix_proxy.dpatch by Nicolas Baradakis <nbk@sitadelle.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fix proxy port setting
 
6
## DP: dpatch'd by Mark Hymers <mark@hymers.org.uk>
 
7
 
 
8
@DPATCH@
 
9
 
 
10
diff -u -r1.36.2.6.2.2 mainconfig.c
 
11
--- old/src/main/mainconfig.c   18 Apr 2006 17:26:26 -0000      1.36.2.6.2.2
 
12
+++ new/src/main/mainconfig.c   18 Sep 2006 11:30:26 -0000
 
13
@@ -381,13 +381,13 @@
 
14
                 */
 
15
                if ((authhost = cf_section_value_find(cs, "authhost")) == NULL) {
 
16
                        c->ipaddr = htonl(INADDR_NONE);
 
17
-                       c->auth_port = auth_port;
 
18
+                       c->auth_port = 0;
 
19
                } else {
 
20
                        if ((s = strchr(authhost, ':')) != NULL) {
 
21
                                *s++ = 0;
 
22
                                c->auth_port = atoi(s);
 
23
                        } else {
 
24
-                               c->auth_port = auth_port;
 
25
+                               c->auth_port = PW_AUTH_UDP_PORT;
 
26
                        }
 
27
                        if (strcmp(authhost, "LOCAL") == 0) {
 
28
                                /*
 
29
@@ -395,7 +395,7 @@
 
30
                                 *      secret, or port.
 
31
                                 */
 
32
                                c->ipaddr = htonl(INADDR_NONE);
 
33
-                               c->auth_port = auth_port;
 
34
+                               c->auth_port = 0;
 
35
                        } else {
 
36
                                c->ipaddr = ip_getaddr(authhost);
 
37
                                if (c->ipaddr == htonl(INADDR_NONE)) {
 
38
@@ -429,7 +429,7 @@
 
39
                                *s++ = 0;
 
40
                                c->acct_port = atoi(s);
 
41
                        } else {
 
42
-                               c->acct_port = auth_port + 1;
 
43
+                               c->acct_port = PW_ACCT_UDP_PORT;
 
44
                        }
 
45
                        if (strcmp(accthost, "LOCAL") == 0) {
 
46
                                /*
 
47