~ubuntu-branches/ubuntu/feisty/xorg-server/feisty-updates

« back to all changes in this revision

Viewing changes to debian/patches/129_remove_extra_i2c_bittimeout.patch

  • Committer: Bazaar Package Importer
  • Author(s): Timo Aaltonen
  • Date: 2007-03-29 00:56:17 UTC
  • Revision ID: james.westby@ubuntu.com-20070329005617-71dz9x5jr1xv3aly
Tags: 2:1.2.0-3ubuntu6
* debian/{rules,xsfbs/xsfbs.mk,serverminver,inputabiver}
  - Import changes from current debian package, needed for the new intel
    driver.
  - Rename serverabiver to videoabiver, value 1.0.
  - Set serverminver as this version.
* debian/patches:
  129_remove_extra_i2c_bittimeout.patch
  130_slow_down_ddc_i2c.patch
  - Patches from server-1.3 branch, which make probing the monitor more
    robust.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Keith Packard <keithp@neko.keithp.com>
 
2
Date: Sun, 18 Mar 2007 00:26:11 +0000 (-0700)
 
3
Subject: Remove extra (and wrong) I2C ByteTimeout setting in DDC code.
 
4
X-Git-Tag: xf-3_9_16d / xf-3_9_16e / xf-3_9_16f / xf-3_9_16Z
 
5
X-Git-Url: http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=commitdiff;h=52fccb9d9fdbb1c9dc3f5225600004cd94e42a4a
 
6
 
 
7
Remove extra (and wrong) I2C ByteTimeout setting in DDC code.
 
8
 
 
9
The DDC code sets the I2C timeouts to VESA standards, except that it had an
 
10
extra setting of the ByteTimeout value which was wrong (off by a factor of
 
11
50). Removing this should help DDC work on many more monitors. Note that the
 
12
Intel driver duplicated these settings, along with the error. Yay for cult
 
13
and paste coding.
 
14
---
 
15
 
 
16
--- a/hw/xfree86/ddc/xf86DDC.c
 
17
+++ b/hw/xfree86/ddc/xf86DDC.c
 
18
@@ -344,7 +344,6 @@ DDCRead_DDC2(int scrnIndex, I2CBusPtr pB
 
19
        dev->ByteTimeout = 2200; /* VESA DDC spec 3 p. 43 (+10 %) */
 
20
        dev->StartTimeout = 550;
 
21
        dev->BitTimeout = 40;
 
22
-       dev->ByteTimeout = 40;
 
23
        dev->AcknTimeout = 40;
 
24
 
 
25
        dev->pI2CBus = pBus;
 
26