~ubuntu-branches/ubuntu/gutsy/cyrus-sasl2/gutsy-201105300151

« back to all changes in this revision

Viewing changes to debian/patches/02_versioned_symbols.diff

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2006-11-27 12:59:40 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20061127125940-na3q3g3tkydvyvgl
Tags: 2.1.22.dfsg1-4ubuntu1
* Merge from debian unstable, remaining changes:
  - remove stop links from rc0 and rc6
  - build against db4.3 instead of 4.2
  - build against heimdal-dev instead of libkrb5-dev
  - depend on, don't recommend, modules

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nru3 ./cyrus-sasl-2.1.19.dfsg1/lib/Makefile.am ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/lib/Makefile.am
2
 
--- ./cyrus-sasl-2.1.19.dfsg1/lib/Makefile.am   2004-07-02 20:39:36.000000000 +0100
3
 
+++ ../build-tree.new/cyrus-sasl-2.1.19.dfsg1/lib/Makefile.am   2004-07-17 19:07:03.000000000 +0100
4
 
@@ -60,8 +60,8 @@
5
 
 lib_LTLIBRARIES = libsasl2.la
6
 
 
7
 
 libsasl2_la_SOURCES = $(common_sources) $(common_headers)
8
 
-libsasl2_la_LDFLAGS = -version-info $(sasl_version)
9
 
-libsasl2_la_DEPENDENCIES = $(LTLIBOBJS)
10
 
+libsasl2_la_LDFLAGS = -version-info $(sasl_version) -Wl,--version-script=Versions
11
 
+libsasl2_la_DEPENDENCIES = $(LTLIBOBJS) Versions
12
 
 libsasl2_la_LIBADD = $(LTLIBOBJS) $(SASL_DL_LIB) $(LIB_SOCKET) $(LIB_DOOR)
13
 
 
14
 
 if MACOSX
15
 
@@ -92,3 +92,10 @@
16
 
        libsasl2.la >TMP.$$ && mv TMP.$$ libsasl2.la
17
 
        rm -f $@
18
 
        ln -s .libs/$@ $@
19
 
+
20
 
+Versions: $(libsasl2_la_OBJECTS)
21
 
+       rm -f $@
22
 
+       echo "SASL2 {" > $@
23
 
+       echo "  global:" >> $@
24
 
+       nm $(patsubst %.lo,%.o,$(libsasl2_la_OBJECTS)) | grep " [Tt] " | cut -d" " -f3 | sed -e 's/$$/;/' >>$@
25
 
+       echo "};" >> $@