~ubuntu-branches/ubuntu/hardy/avidemux/hardy

« back to all changes in this revision

Viewing changes to debian/patches/02_powerpc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Matvey Kozhev
  • Date: 2008-01-23 14:24:55 UTC
  • mfrom: (1.1.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20080123142455-wznqmv3teznzpmjb
Tags: 1:2.4.0-0.3ubuntu1
* Merged new upstream release from debian-multimedia.org
  (LP: #178845, LP: #180393), remaining Ubuntu changes:
  + debian/control:
    - set maintainer fields per Ubuntu policy.
    - removed libamrnb-dev, not in Ubuntu and most likely
      will never be (due to being proprietary software).
    - build against current libx264-dev (LP: #177082).
    - build against current libfaac-dev (LP: #181389).
    - build-depend on chrpath to strip rpath from avidemux2_qt4.
  + debian/rules: strip rpath from avidemux2_qt4.
  + debian/source.lintian-overrides: re-added.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- avidemux_2.4.0/avidemux/ADM_userInterfaces/ADM_commonUI/DIA_builtin.cpp     2008-01-09 10:25:12.000000000 +0100
 
2
+++ avidemux_2.4.0/avidemux/ADM_userInterfaces/ADM_commonUI/DIA_builtin.cpp     2008-01-09 10:26:54.000000000 +0100
 
3
@@ -45,9 +45,9 @@
 
4
 {
 
5
   uint32_t altivec=0,mad=0,a52dec=0,xvid4=0,X264=0,freetype=0,esd=0,arts=0,vorbis=0,win32=0;
 
6
   uint32_t faac=0,faad=0,libdca=0,aften=0,libamrnb=0,lame=0,sdl=0,oss=0,xvideo=0,x86=0,x86_64=0,alsa=0;
 
7
-  uint32_t powerpc=0,gettext=0,fontconfig=0;
 
8
+  uint32_t adm_powerpc=0,adm_gettext=0,adm_fontconfig=0;
 
9
 #ifdef USE_FONTCONFIG
 
10
-  fontconfig=1;
 
11
+  adm_fontconfig=1;
 
12
 #endif
 
13
 #ifdef USE_ALTIVEC
 
14
         altivec=1;
 
15
@@ -119,10 +119,10 @@
 
16
        x86_64=1;
 
17
 #endif
 
18
 #ifdef ARCH_POWERPC
 
19
-       powerpc=1;
 
20
+       adm_powerpc=1;
 
21
 #endif
 
22
 #ifdef HAVE_GETTEXT
 
23
-       gettext=1;
 
24
+       adm_gettext=1;
 
25
 #endif
 
26
     
 
27
        diaElemFrame videoFrame(QT_TR_NOOP("Video Codecs"));
 
28
@@ -155,16 +155,16 @@
 
29
 
 
30
        diaElemNotch tArts(arts, QT_TR_NOOP("aRts"));
 
31
        diaElemNotch tEsd(esd, QT_TR_NOOP("ESD"));
 
32
-        diaElemNotch tFontConfig(fontconfig, QT_TR_NOOP("Fontconfig"));
 
33
+        diaElemNotch tFontConfig(adm_fontconfig, QT_TR_NOOP("Fontconfig"));
 
34
        diaElemNotch tFreetype(freetype, QT_TR_NOOP("FreeType 2"));
 
35
-       diaElemNotch tGettext(gettext, QT_TR_NOOP("gettext"));
 
36
+       diaElemNotch tGettext(adm_gettext, QT_TR_NOOP("gettext"));
 
37
         diaElemNotch tAlsa(alsa, QT_TR_NOOP("ALSA"));
 
38
        diaElemNotch tOss(oss, QT_TR_NOOP("OSS"));
 
39
        diaElemNotch tSdl(sdl, QT_TR_NOOP("SDL"));
 
40
        diaElemNotch tXvideo(xvideo, QT_TR_NOOP("XVideo"));
 
41
 
 
42
        diaElemNotch tAltivec(altivec, QT_TR_NOOP("AltiVec"));
 
43
-       diaElemNotch tPowerPc(powerpc, QT_TR_NOOP("PowerPC"));
 
44
+       diaElemNotch tPowerPc(adm_powerpc, QT_TR_NOOP("PowerPC"));
 
45
        diaElemNotch tX86(x86, QT_TR_NOOP("x86"));
 
46
        diaElemNotch tX86_64(x86_64, QT_TR_NOOP("x86-64"));
 
47