~ubuntu-branches/ubuntu/hardy/fetchmail/hardy-security

« back to all changes in this revision

Viewing changes to debian/patches/04_fix_CVE-2007-4565_DoS.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Bienia
  • Date: 2007-09-05 12:06:26 UTC
  • Revision ID: james.westby@ubuntu.com-20070905120626-0h6uwhpmkdewdscg
Tags: 6.3.8-8ubuntu1
* Merge to Debian unstable:
  - build with gssapi support (LP: #27616)
* Remaining Ubuntu changes:
  - debian/fetchmail.postinst: Use multiuser update-rc.d mode (TearDown).
  - debian/fetchmail.postinst: Remove shutdown and reboot rc links on
    upgrades. This needs to be kept until the next LTS release.
  - debian/control: exim4 -> postfix suggestion (this is an unimportant
    change now, so should the multiuser change ever go into Debian, this can
    be dropped).
  - debian/control: Set Ubuntu maintainer.
* debian/fetchmailconf.menu:
  - Fix lintian error about the menu section for fetchmailconf.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -urNad fetchmail-6.3.8~/sink.c fetchmail-6.3.8/sink.c
 
2
--- fetchmail-6.3.8~/sink.c     2007-03-30 00:45:17.000000000 +0200
 
3
+++ fetchmail-6.3.8/sink.c      2007-08-29 12:03:20.000000000 +0200
 
4
@@ -262,7 +262,7 @@
 
5
     const char *md1 = "MAILER-DAEMON", *md2 = "MAILER-DAEMON@";
 
6
 
 
7
     /* don't bounce in reply to undeliverable bounces */
 
8
-    if (!msg->return_path[0] ||
 
9
+    if (!msg || !msg->return_path[0] ||
 
10
        strcmp(msg->return_path, "<>") == 0 ||
 
11
        strcasecmp(msg->return_path, md1) == 0 ||
 
12
        strncasecmp(msg->return_path, md2, strlen(md2)) == 0)