~ubuntu-branches/ubuntu/hardy/gdm/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/50_close-fds.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2007-12-11 15:34:43 UTC
  • mfrom: (1.4.22 upstream)
  • Revision ID: james.westby@ubuntu.com-20071211153443-ndi1b5u2d6oybb7p
Tags: 2.20.2-1ubuntu1
* Sync with Debian
* debian/control.in:
  - Breaks on packages using the previous socket location
  - Depend on kbd | console-tools for fgconsole
  - Depends on alsa-utils for gdmplay
  - Recommends ubuntu-artwork | edubuntu-artwork | xubuntu-default-settings, 
    ubuntu-sounds
  - the package in maintained by the desktop team on Ubuntu
* debian/control.in, debian/gdm.dirs, debian/gdm.install:
  - don't install the Debian theme
* debian/gdm.init:
  - use the Ubuntu init version
* debian/gdm.install:
  - list gdmplay binary
* debian/gdm.templates:
  - Fix template to point to /usr/sbin/gdm not /usr/bin. (LP: 129017)
* debian/gdmplay:
  - small asound wrapper
* debian/patches/01_xconfigoptions.patch:
  - patch configure to use "-br" (Ubuntu: #12985).
* debian/patches/01_xrdb_nocpp.patch:
  - call xrdb with the "nocpp" option (Ubuntu: #14268).
* debian/patches/04_menu_changes.patch:
  - don't display some of the menu items
* debian/patches/06_no_conffile_diff_due_to_comment_change.patch:
  - don't change comments to gdm.conf-custom to not get a conffile change
    on upgrade (Ubuntu: #92302)
* debian/patches/08_notify_ck_about_static_server.patch:
  - "Notify ck about initial static server."
* debian/patches/10_noxkeepcrashing.patch:
  - option NoXKeepsCrashing to disable all XKeepsCrashing code.
* debian/patches/11_powermanagement.patch:
  - add hibernate action
  - fix typo in the hibernate command configuration (LP: #151788)
  - make the hibernate action being listed (LP: #151848)
* debian/patches/15_usplash.patch:
  - Log that we're starting up gdm before stopping usplash. If usplash was
    running, don't bother logging successful startup, as it will look
    weird on the console.
  - If usplash was running, wait a short while for the active console to
    change after starting up gdm, to try to avoid visible console noise
    from later init scripts
* debian/patches/16_configure_menu_item.patch:
  - drop the configure option from gdmsetup, it's not sudo friendly
* debian/patches/18_combo_box_language_selector.patch:
  - use a combo box for the language selector
* debian/patches/19_remove_drop_shadows.patch:
  - removed the black drop shadow from GDM windows, 
* debian/patches/20_timedlogindelay_min_value_change.patch:
  - change minimal TimedLoginDelay to 1 (Ubuntu: #84239)
* debian/patches/35_gdm.conf.patch:
  - SuspendCommand=/usr/sbin/pmi action sleep
  - HibernateCommand=/usr/sbin/pmi action hibernate
  - SoundProgram=/usr/lib/gdmplay
  - GtkTheme=Human
  - ConfigAvailable=false
  - BackgroundColor=#dab08
  - GraphicalThemedColor=#dab082
  - use "Browser=true" so the users lists work correctly (LP: 115952)
  - set SoundOnLoginFile value to question.wav (LP: 131601)
* debian/patches/41_config-files.patch:
  - dropped, don't use Debian configuration file location hack
* debian/patches/56_xnest-wrapper.patch:
  - updated
* debian/patches/63_xrandr_virtual.patch:
  - on randr1.0 drivers, set the virtual to the screen resolution in 
    order to avoid panning setups (part of LP: 137517)
* debian/patches/70_mandatory-relibtoolize.patch:
  - updated
* debian/patches/90_workaround_init_color.patch:
  - set the color to use in the PreSession to workaround a bug
* debian/rules:
  - change custom configuration file naming
  - set the standard configuration location
  - specify the correct at-spi directory

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
 
3
3
XXX needs to be clarified and perhaps merged upstream
4
4
 
5
 
Index: gdm-2.18.2/daemon/display.c
 
5
Index: gdm-2.20.0/daemon/display.c
6
6
===================================================================
7
 
--- gdm-2.18.2.orig/daemon/display.c    2007-05-29 10:37:47.000000000 +0200
8
 
+++ gdm-2.18.2/daemon/display.c 2007-05-29 10:38:30.000000000 +0200
9
 
@@ -306,8 +306,17 @@
 
7
--- gdm-2.20.0.orig/daemon/display.c    2007-09-17 16:45:50.000000000 +0200
 
8
+++ gdm-2.20.0/daemon/display.c 2007-10-06 16:22:16.537644959 +0200
 
9
@@ -387,8 +387,17 @@
10
10
 
11
 
        closelog ();
 
11
        gdm_log_shutdown ();
12
12
 
13
13
-       /* Close everything */
14
14
-       gdm_close_all_descriptors (0 /* from */, fds[0] /* except */, slave_fifo_pipe_fd /* except2 */);
26
26
 
27
27
        /* No error checking here - if it's messed the best response
28
28
          * is to ignore & try to continue */
29
 
Index: gdm-2.18.2/daemon/slave.c
 
29
Index: gdm-2.20.0/daemon/slave.c
30
30
===================================================================
31
 
--- gdm-2.18.2.orig/daemon/slave.c      2007-05-29 10:37:47.000000000 +0200
32
 
+++ gdm-2.18.2/daemon/slave.c   2007-05-29 10:38:30.000000000 +0200
33
 
@@ -1648,6 +1648,9 @@
 
31
--- gdm-2.20.0.orig/daemon/slave.c      2007-09-17 16:45:50.000000000 +0200
 
32
+++ gdm-2.20.0/daemon/slave.c   2007-10-06 16:22:16.541645187 +0200
 
33
@@ -1745,6 +1745,9 @@
34
34
 
35
 
        closelog ();
 
35
        gdm_log_shutdown ();
36
36
 
37
37
+       /* Debian changes */
38
38
+#if 0
40
40
        gdm_close_all_descriptors (0 /* from */, p[1] /* except */, -1 /* except2 */);
41
41
 
42
42
        /* No error checking here - if it's messed the best response
43
 
@@ -1655,6 +1658,17 @@
 
43
@@ -1752,6 +1755,17 @@
44
44
        gdm_open_dev_null (O_RDONLY); /* open stdin - fd 0 */
45
45
        gdm_open_dev_null (O_RDWR); /* open stdout - fd 1 */
46
46
        gdm_open_dev_null (O_RDWR); /* open stderr - fd 2 */
56
56
+       gdm_open_dev_null (O_RDWR); /* open stdout - fd 1 */
57
57
+       /* End of Debian changes */
58
58
 
59
 
        openlog ("gdm", LOG_PID, LOG_DAEMON);
60
 
 
61
 
@@ -1810,6 +1824,9 @@
62
 
 
63
 
                closelog ();
 
59
        gdm_log_init ();
 
60
 
 
61
@@ -1912,6 +1926,9 @@
 
62
 
 
63
                gdm_log_shutdown ();
64
64
 
65
65
+               /* Debian changes */
66
66
+#if 0
68
68
                gdm_close_all_descriptors (0 /* from */, slave_fifo_pipe_fd /* except */, d->slave_notify_fd /* except2 */);
69
69
 
70
70
                /* No error checking here - if it's messed the best response
71
 
@@ -1817,6 +1834,17 @@
 
71
@@ -1919,6 +1936,17 @@
72
72
                gdm_open_dev_null (O_RDONLY); /* open stdin - fd 0 */
73
73
                gdm_open_dev_null (O_RDWR); /* open stdout - fd 1 */
74
74
                gdm_open_dev_null (O_RDWR); /* open stderr - fd 2 */
84
84
+               gdm_open_dev_null (O_RDWR); /* open stdout - fd 1 */
85
85
+               /* End of Debian changes */
86
86
 
87
 
                openlog ("gdm", LOG_PID, LOG_DAEMON);
 
87
                gdm_log_init ();
88
88