~ubuntu-branches/ubuntu/hardy/glibc/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/hurd-i386/local-pthread_stubs.diff

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2008-04-03 21:50:42 UTC
  • Revision ID: james.westby@ubuntu.com-20080403215042-nstfsfokfxagm2k8
Tags: 2.7-10ubuntu1
* Merge remaining changes from 2.7-10 (r2869:2892).
* If RELEASE_UPGRADE_MODE is set to `desktop', make the glibc/restart-services,
  glibc/restart-failed and glibc/upgrade questions of medium priority (and
  restarting the services automatically).  LP: #174002.
  Works as well around the upgrade errors mentioned in LP #205079 in a KDE
  environment, when the upgrade is done using the update-manager.
* debian/rules: Always use the package settings for *FLAGS, not the settings
  from the environment.
* Fail the build if regressions are found running the testsuite compared to
  expected results from debian/expected_test_summary. Take initial values
  from a PPA build predating this upload.
* Merge from Debian trunk:
  - local/manpages/ld.so.8: fix libraries search order.  Closes: #473458.
  - Update Finish debconf translation, by Esko Arajärvi.  Closes: #473802.
  - Add any/cvs-strerror_r.diff to make strerror_r actually thread safe.
    Closes: #456531.
* debian/rules.d/build.mk: Call `sync' before building the tarball of
  supported locales. Our buildds trigger http://lkml.org/lkml/2007/8/1/337
  on every build.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: Makerules
 
2
===================================================================
 
3
RCS file: /cvs/glibc/libc/Makerules,v
 
4
retrieving revision 1.450
 
5
diff -u -p -r1.450 Makerules
 
6
--- glibc/Makerules     26 Aug 2007 02:18:03 -0000      1.450
 
7
+++ glibc/Makerules     21 Jan 2008 09:41:42 -0000
 
8
@@ -993,7 +993,8 @@ $(inst_libdir)/libc.so: $(common-objpfx)
 
9
         cat $<; \
 
10
         echo 'GROUP ( $(slibdir)/libc.so$(libc.so-version)' \
 
11
              '$(libdir)/$(patsubst %,$(libtype.oS),$(libprefix)$(libc-name))'\
 
12
-             ' AS_NEEDED (' $(slibdir)/$(rtld-installed-name) ') )' \
 
13
+             ' AS_NEEDED (' $(slibdir)/$(rtld-installed-name) ') )' ;\
 
14
+        echo 'INPUT ( AS_NEEDED ( -lpthread-stubs ) )' \
 
15
        ) > $@.new
 
16
        mv -f $@.new $@
 
17
 
 
18
Index: sysdeps/mach/hurd/libc-ldscript
 
19
===================================================================
 
20
RCS file: /cvs/glibc/libc/sysdeps/mach/hurd/libc-ldscript,v
 
21
retrieving revision 1.2
 
22
diff -u -p -r1.2 libc-ldscript
 
23
--- glibc/sysdeps/mach/hurd/libc-ldscript       4 Dec 1996 01:41:11 -0000       1.2
 
24
+++ glibc/sysdeps/mach/hurd/libc-ldscript       20 Jan 2008 22:19:41 -0000
 
25
@@ -4,3 +4,4 @@
 
26
    */
 
27
 
 
28
 GROUP ( libcrt.a libmachuser.a libhurduser.a )
 
29
+INPUT ( -lpthread-stubs )