~ubuntu-branches/ubuntu/hardy/mysql-dfsg-5.0/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/29_scripts__mysqlbug.sh.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2007-04-02 16:10:53 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20070402161053-zkil9hjq9k5p1uzv
Tags: 5.0.37-0ubuntu1
* New upstream bugfix release.
  - Fixes replication failure with auto-increment and on duplicate key
    update, a regression introduced into 5.0.24. (LP: #95821)
* debian/control: Set Ubuntu maintainer.
* debian/rules: Change comments from 'Debian etch' to 'Ubuntu 7.04'.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 29_scripts__mysqlbug.sh.dpatch by  <ch@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: scripts__mysqlbug.sh
6
 
 
7
 
@DPATCH@
8
 
 
9
 
#
10
 
# 1. Debian specific defaults
11
 
#
12
 
--- old/scripts/mysqlbug.sh.orig        2004-05-31 23:31:42.000000000 +0200
13
 
+++ new/scripts/mysqlbug.sh     2004-05-31 23:32:07.000000000 +0200
14
 
@@ -132,7 +132,9 @@
15
 
 then
16
 
   if test -z "$EDITOR"
17
 
   then
18
 
-    EDIT=emacs
19
 
+    # EDIT=emacs
20
 
+    # in Debian, we have the sensible-editor symlink. -ch-
21
 
+    EDIT=sensible-editor
22
 
   else
23
 
     EDIT="$EDITOR"
24
 
   fi