~ubuntu-branches/ubuntu/hardy/mysql-dfsg-5.0/hardy

« back to all changes in this revision

Viewing changes to debian/patches/57-fix-mysqlslowdump-config.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mathias Gug, Mathias Gug, Chuck Short
  • Date: 2008-01-25 04:10:49 UTC
  • mfrom: (1.1.14 upstream)
  • Revision ID: james.westby@ubuntu.com-20080125041049-9v0lza2vm6jfv1uf
Tags: 5.0.51-3ubuntu1
[Mathias Gug]
* Merge from debian unstable, remaining changes:
  - debian/control:
    - Set Maintainer to Ubuntu Core dev. Move Debian maintainer
      to XSBC-Original-Maintainer.
    - Add mysql-doc-5.0 as a Suggests to mysql-client-5.0,  mysql-server-5.0
      and libmysqlclient15-dev.
  - debian/rules: Apply same configuration options on lpia as for i386.
* debian/control:
  - Preprend XS-Original- to Vcs-{Browser,Svn}.
* debian/rules:
  - Support DEB_BUILD_OPTIONS option 'nocheck' to skip tests.
* Dropped patches:
  - debian/patches/91_bug29389.dpatch:
      fix for mysql bug 27383 which causes mysql-test 'mysql_client_test'
      to fail due to gcc 4.x optimizations.
  - debian/libmysqlclient15-dev.files, debian/mysql-client-5.0.files,
    debian/mysql-server-5.0.files: man pages are GPLed now.
* Improved error message when unable to connect using debian-sys-maint. (LP:
  #153868)

[Chuck Short]
* Replcaed --with-comment="Debian" with --with-comment="Ubuntu" in debian/rules  (LP: #134384)
* Added note about the "/etc/mysql/conf.d" directory in my.cnf (LP: #136225)
* Fixed mysqlhotcopy failure. (LP: #162393)
* Fixed mysqlslowdump usage.  Added patch from Arnold Daniels <info@adaniels.nl>. (LP: #183762)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
 
 
3
@DPATCH@
 
4
diff -Naur mysql-dfsg-5.0-5.0.45.orig/scripts/mysqldumpslow.sh mysql-dfsg-5.0-5.0.45/scripts/mysqldumpslow.sh
 
5
--- mysql-dfsg-5.0-5.0.45.orig/scripts/mysqldumpslow.sh 2007-07-04 09:06:41.000000000 -0400
 
6
+++ mysql-dfsg-5.0-5.0.45/scripts/mysqldumpslow.sh      2008-02-04 08:04:14.000000000 -0500
 
7
@@ -34,13 +34,13 @@
 
8
 $opt{'help'} and usage();
 
9
 
 
10
 unless (@ARGV) {
 
11
-    my $defaults   = `my_print_defaults mysqld`;
 
12
+    my $defaults   = `my_print_defaults mysqld -c -c /etc/mysql/my.cnf`;
 
13
     my $basedir = ($defaults =~ m/--basedir=(.*)/)[0]
 
14
-       or die "Can't determine basedir from 'my_print_defaults mysqld' output: $defaults";
 
15
+       or die "Can't determine basedir from 'my_print_defaults mysqld' -c -c /etc/mysql/my.cnf output: $defaults";
 
16
     warn "basedir=$basedir\n" if $opt{v};
 
17
 
 
18
     my $datadir = ($defaults =~ m/--datadir=(.*)/)[0];
 
19
-    my $slowlog = ($defaults =~ m/--log-slow-queries=(.*)/)[0];
 
20
+    my $slowlog = ($defaults =~ m/--log[-_]slow[-_]queries=(.*)/)[0];
 
21
     if (!$datadir or $opt{i}) {
 
22
        # determine the datadir from the instances section of /etc/my.cnf, if any
 
23
        my $instances  = `my_print_defaults instances`;