~ubuntu-branches/ubuntu/hardy/ruby1.8/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/902_extra_search_path.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): akira yamada
  • Date: 2007-03-13 22:11:58 UTC
  • mfrom: (1.1.5 upstream)
  • Revision ID: james.westby@ubuntu.com-20070313221158-h3oql37brlaf2go2
Tags: 1.8.6-1
* new upstream version, 1.8.6.
* libruby1.8 conflicts with libopenssl-ruby1.8 (< 1.8.6) (closes: #410018)
* changed packaging style to cdbs from dbs.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 902_extra_search_path.dpatch by akira yamada <akira@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad ruby1.8-1.8.6~/configure.in ruby1.8-1.8.6/configure.in
 
9
--- ruby1.8-1.8.6~/configure.in 2007-02-28 22:23:42.000000000 +0900
 
10
+++ ruby1.8-1.8.6/configure.in  2007-03-13 16:33:00.000000000 +0900
 
11
@@ -1618,6 +1618,19 @@
 
12
     AC_DEFINE_UNQUOTED(RUBY_SEARCH_PATH,"$search_path")
 
13
 fi
 
14
 
 
15
+AC_ARG_WITH(extra-site-search-path,
 
16
+               [  --with-extra-site-search-path=DIR specify the extra site search path],
 
17
+               [extra_site_search_path=$withval])
 
18
+if test "$extra_site_search_path" != ""; then
 
19
+    AC_DEFINE_UNQUOTED(RUBY_EXTRA_SITE_SEARCH_PATH,"$extra_site_search_path")
 
20
+fi
 
21
+AC_ARG_WITH(extra-search-path,
 
22
+               [  --with--site-search-path=DIR specify the extra search path],
 
23
+               [extra_search_path=$withval])
 
24
+if test "$extra_search_path" != ""; then
 
25
+    AC_DEFINE_UNQUOTED(RUBY_EXTRA_SEARCH_PATH,"$extra_search_path")
 
26
+fi
 
27
+
 
28
 AC_ARG_WITH(mantype,
 
29
                [  --with-mantype=TYPE specify man page type; TYPE is one of man and doc],
 
30
                [
 
31
diff -urNad ruby1.8-1.8.6~/ruby.c ruby1.8-1.8.6/ruby.c
 
32
--- ruby1.8-1.8.6~/ruby.c       2007-02-13 08:01:19.000000000 +0900
 
33
+++ ruby1.8-1.8.6/ruby.c        2007-03-13 16:33:11.000000000 +0900
 
34
@@ -296,6 +296,9 @@
 
35
     ruby_incpush(RUBY_RELATIVE(RUBY_SITE_THIN_ARCHLIB));
 
36
 #endif
 
37
     ruby_incpush(RUBY_RELATIVE(RUBY_SITE_ARCHLIB));
 
38
+#ifdef RUBY_EXTRA_SITE_SEARCH_PATH
 
39
+    ruby_incpush(RUBY_RELATIVE(RUBY_EXTRA_SITE_SEARCH_PATH));
 
40
+#endif
 
41
     ruby_incpush(RUBY_RELATIVE(RUBY_SITE_LIB));
 
42
 
 
43
     ruby_incpush(RUBY_RELATIVE(RUBY_LIB));
 
44
@@ -303,6 +306,9 @@
 
45
     ruby_incpush(RUBY_RELATIVE(RUBY_THIN_ARCHLIB));
 
46
 #endif
 
47
     ruby_incpush(RUBY_RELATIVE(RUBY_ARCHLIB));
 
48
+#ifdef RUBY_EXTRA_SEARCH_PATH
 
49
+    ruby_incpush(RUBY_RELATIVE(RUBY_EXTRA_SEARCH_PATH));
 
50
+#endif
 
51
 
 
52
     if (rb_safe_level() == 0) {
 
53
        ruby_incpush(".");