~ubuntu-branches/ubuntu/hardy/thunderbird/hardy

« back to all changes in this revision

Viewing changes to debian/patches/moz-user-dir-for-xre-profiles

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack
  • Date: 2007-04-23 13:15:00 UTC
  • Revision ID: james.westby@ubuntu.com-20070423131500-oo8zeerbajzsnx7p
Tags: 2.0.0.0-0ubuntu1
* bump version to 2.0.0.0 in preparation of official upload
* debian/patches/mailnews_mime_export: added patch to export mime headers:
  mimecryp.h + mimemoz2.h - needed by enigmail
* debian/patches/series: add patch to quilt series accordingly
* debian/rules: use --with-user-appdir configure option to set MOZ_USER_DIR
* debian/patches/moz-user-dir-for-xre-profiles: fix xre dir provider to
  honour MOZ_USER_DIR
* debian/patches/ubuntu-mail-app-xre-name: drop old nsXREAppData tweak to
  use .mozilla-thunderbird as profile directory
* debian/patches/syspref-folder-support: add syspref folder support
* debian/patches/reply-to-list-support: port reply-to-list-support to 2.0
  branch
* debian/patches/series: update quilt patch series accordingly

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
 toolkit/xre/nsXREDirProvider.cpp |    8 ++++++++
 
3
 1 file changed, 8 insertions(+)
 
4
 
 
5
Index: mozilla/toolkit/xre/nsXREDirProvider.cpp
 
6
===================================================================
 
7
--- mozilla.orig/toolkit/xre/nsXREDirProvider.cpp       2007-04-23 17:10:23.000000000 +0200
 
8
+++ mozilla/toolkit/xre/nsXREDirProvider.cpp    2007-04-23 17:10:31.000000000 +0200
 
9
@@ -860,21 +860,29 @@
 
10
   char* writing = profileFolderName + 1;
 
11
   if (gAppData->vendor) {
 
12
     GetProfileFolderName(writing, gAppData->vendor);
 
13
     
 
14
     rv = localDir->AppendNative(nsDependentCString(profileFolderName));
 
15
     NS_ENSURE_SUCCESS(rv, rv);
 
16
  
 
17
     char temp[MAXPATHLEN];
 
18
+#ifndef MOZ_USER_DIR
 
19
     GetProfileFolderName(temp, gAppData->name);
 
20
+#else
 
21
+    GetProfileFolderName(temp, MOZ_USER_DIR + 1);
 
22
+#endif
 
23
     appNameFolder = temp;
 
24
   }
 
25
   else {
 
26
+#ifndef MOZ_USER_DIR
 
27
     GetProfileFolderName(writing, gAppData->name);
 
28
+#else
 
29
+    GetProfileFolderName(writing, MOZ_USER_DIR + 1);
 
30
+#endif
 
31
     appNameFolder = profileFolderName;
 
32
   }
 
33
   rv = localDir->AppendNative(nsDependentCString(appNameFolder));
 
34
   NS_ENSURE_SUCCESS(rv, rv);
 
35
 #else
 
36
 #error dont_know_how_to_get_product_dir_on_your_platform
 
37
 #endif
 
38