~ubuntu-branches/ubuntu/hardy/xserver-xorg-video-ati/hardy

« back to all changes in this revision

Viewing changes to debian/patches/08_disable_dri_rc410.diff

  • Committer: Bazaar Package Importer
  • Author(s): Timo Aaltonen
  • Date: 2007-10-06 12:13:31 UTC
  • mfrom: (1.1.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20071006121331-l0jcbuztjsmie3a9
Tags: 1:6.7.195-1ubuntu1
* Merge with Debian experimental, remaining changes:
  - debian/control
    * Ease the Build-Depends on xserver-xorg-dev.
    * Change Maintainer-address.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: xserver-xorg-video-ati-6.7.194/src/radeon_driver.c
2
 
===================================================================
3
 
--- xserver-xorg-video-ati-6.7.194.orig/src/radeon_driver.c     2007-10-03 19:42:00.000000000 +0200
4
 
+++ xserver-xorg-video-ati-6.7.194/src/radeon_driver.c  2007-10-03 19:42:30.000000000 +0200
5
 
@@ -2026,15 +2026,17 @@
6
 
     info->pKernelDRMVersion = NULL;
7
 
 
8
 
     if (info->Chipset == PCI_CHIP_RN50_515E ||
9
 
-       info->Chipset == PCI_CHIP_RN50_5969) {
10
 
+       info->Chipset == PCI_CHIP_RN50_5969 ||
11
 
+       info->Chipset == PCI_CHIP_RC410_5A61 ||
12
 
+       info->Chipset == PCI_CHIP_RC410_5A62) {
13
 
        if (xf86ReturnOptValBool(info->Options, OPTION_DRI, FALSE)) {
14
 
            xf86DrvMsg(pScrn->scrnIndex, X_WARNING,
15
 
-               "Direct rendering for RN50 forced on -- "
16
 
+               "Direct rendering for RN50/RC410 forced on -- "
17
 
                "This is NOT officially supported at the hardware level "
18
 
                "and may cause instability or lockups\n");
19
 
        } else {
20
 
            xf86DrvMsg(pScrn->scrnIndex, X_INFO,
21
 
-               "Direct rendering not officially supported on RN50\n");
22
 
+               "Direct rendering not officially supported on RN50/RC410\n");
23
 
            return FALSE;
24
 
        }
25
 
     }