~ubuntu-branches/ubuntu/hoary/grub/hoary

« back to all changes in this revision

Viewing changes to debian/patches/04xfs_md5_serial.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jason Thomas
  • Date: 2002-02-04 15:35:01 UTC
  • Revision ID: james.westby@ubuntu.com-20020204153501-4dueio3est059vk0
Tags: 0.91-2
added patch from upstream which fixes a typo in the makefile that broke
xfs support, md5crypt, serial support and hercules support

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Naur grub-0.91.orig/stage2/Makefile.am grub-0.91/stage2/Makefile.am
 
2
--- grub-0.91.orig/stage2/Makefile.am   Sun Oct 28 03:04:24 2001
 
3
+++ grub-0.91/stage2/Makefile.am        Mon Feb  4 15:30:56 2002
 
4
@@ -20,7 +20,7 @@
 
5
        fsys_xfs.c stage2.c md5.c
 
6
 libgrub_a_CFLAGS = $(GRUB_CFLAGS) -I$(top_srcdir)/lib \
 
7
        -DGRUB_UTIL=1 -DFSYS_EXT2FS=1 -DFSYS_FAT=1 -DFSYS_FFS=1 \
 
8
-       -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_VSTAFS=1
 
9
+       -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_VSTAFS=1 \
 
10
        -DFSYS_XFS=1 -DUSE_MD5_PASSWORDS=1 \
 
11
        -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1 -fwritable-strings
 
12
 
 
13
diff -Naur grub-0.91.orig/stage2/Makefile.in grub-0.91/stage2/Makefile.in
 
14
--- grub-0.91.orig/stage2/Makefile.in   Tue Jan 15 21:29:05 2002
 
15
+++ grub-0.91/stage2/Makefile.in        Mon Feb  4 15:32:05 2002
 
16
@@ -113,7 +113,9 @@
 
17
 
 
18
 libgrub_a_CFLAGS = $(GRUB_CFLAGS) -I$(top_srcdir)/lib \
 
19
        -DGRUB_UTIL=1 -DFSYS_EXT2FS=1 -DFSYS_FAT=1 -DFSYS_FFS=1 \
 
20
-       -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_VSTAFS=1
 
21
+       -DFSYS_JFS=1 -DFSYS_MINIX=1 -DFSYS_REISERFS=1 -DFSYS_VSTAFS=1 \
 
22
+       -DFSYS_XFS=1 -DUSE_MD5_PASSWORDS=1 \
 
23
+       -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1 -fwritable-strings
 
24
 
 
25
 
 
26
 EXTRA_PROGRAMS = nbloader.exec pxeloader.exec diskless.exec
 
27
@@ -2571,9 +2573,6 @@
 
28
        installdirs maintainer-clean maintainer-clean-generic \
 
29
        mostlyclean mostlyclean-compile mostlyclean-generic tags \
 
30
        uninstall uninstall-am uninstall-info-am uninstall-pkgdataDATA
 
31
-
 
32
-       -DFSYS_XFS=1 -DUSE_MD5_PASSWORDS=1 \
 
33
-       -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1 -fwritable-strings
 
34
 
 
35
 stage2_size.h: pre_stage2
 
36
        -rm -f stage2_size.h