~ubuntu-branches/ubuntu/intrepid/kdebase-workspace/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_15_kickoff_ksmserver_logout.diff

  • Committer: Bazaar Package Importer
  • Author(s): Harald Sitter
  • Date: 2008-10-11 16:36:55 UTC
  • Revision ID: james.westby@ubuntu.com-20081011163655-nepj5auwnf7agmpc
Tags: 4:4.1.2-0ubuntu8
* Remove kubuntu_17_kwin_branch.diff completely
* Fix shutdown where logout was selected, by adding kdisplaymanager.cpp to
  kubuntu_15_kickoff_ksmserver_logout.diff (LP: #279807)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.cpp
2
2
===================================================================
3
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/leavemodel.cpp     2008-09-26 01:33:15.000000000 +0200
4
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.cpp  2008-09-26 01:34:03.000000000 +0200
 
3
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/leavemodel.cpp     2008-02-13 16:45:08.000000000 +0100
 
4
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.cpp  2008-10-11 15:16:18.000000000 +0200
5
5
@@ -27,6 +27,8 @@
6
6
 #include <KLocalizedString>
7
7
 #include <KIcon>
104
104
         systemOptions->appendRow(shutDownOption);
105
105
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.cpp
106
106
===================================================================
107
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/itemhandlers.cpp   2008-09-26 01:33:15.000000000 +0200
108
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.cpp        2008-09-26 01:34:03.000000000 +0200
 
107
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/itemhandlers.cpp   2008-08-28 10:07:05.000000000 +0200
 
108
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.cpp        2008-10-11 15:16:18.000000000 +0200
109
109
@@ -29,6 +29,8 @@
110
110
 #include <KToolInvocation>
111
111
 #include <KUrl>
202
202
+}
203
203
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.h
204
204
===================================================================
205
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/leavemodel.h       2008-09-26 01:33:15.000000000 +0200
206
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.h    2008-09-26 01:34:03.000000000 +0200
 
205
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/leavemodel.h       2008-01-05 00:55:49.000000000 +0100
 
206
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/leavemodel.h    2008-10-11 15:16:18.000000000 +0200
207
207
@@ -36,6 +36,8 @@
208
208
 
209
209
     static QStandardItem* createStandardItem(const QString& url);
215
215
     Private * const d;
216
216
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.h
217
217
===================================================================
218
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/itemhandlers.h     2008-09-26 01:33:15.000000000 +0200
219
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.h  2008-09-26 01:34:03.000000000 +0200
 
218
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/core/itemhandlers.h     2008-02-07 14:19:52.000000000 +0100
 
219
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/core/itemhandlers.h  2008-10-11 15:16:18.000000000 +0200
220
220
@@ -42,6 +42,10 @@
221
221
     void logout();
222
222
     void lock();
230
230
     QString m_logoutAction;
231
231
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/ui/launcher.cpp
232
232
===================================================================
233
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/ui/launcher.cpp 2008-09-26 01:33:15.000000000 +0200
234
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/ui/launcher.cpp      2008-09-26 01:34:03.000000000 +0200
 
233
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/ui/launcher.cpp 2008-08-28 10:07:05.000000000 +0200
 
234
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/ui/launcher.cpp      2008-10-11 15:16:18.000000000 +0200
235
235
@@ -80,6 +80,7 @@
236
236
         , urlLauncher(new UrlItemLauncher(launcher))
237
237
         , resizeHandle(0)
275
275
 Launcher::~Launcher()
276
276
Index: kdebase-workspace-4.1.2/plasma/applets/kickoff/CMakeLists.txt
277
277
===================================================================
278
 
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/CMakeLists.txt  2008-09-26 01:33:15.000000000 +0200
279
 
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/CMakeLists.txt       2008-09-26 01:34:03.000000000 +0200
 
278
--- kdebase-workspace-4.1.2.orig/plasma/applets/kickoff/CMakeLists.txt  2008-08-28 10:07:05.000000000 +0200
 
279
+++ kdebase-workspace-4.1.2/plasma/applets/kickoff/CMakeLists.txt       2008-10-11 15:16:18.000000000 +0200
280
280
@@ -33,6 +33,9 @@
281
281
 QT4_ADD_DBUS_INTERFACE(Kickoff_SRCS ${screensaver_xml} screensaver_interface)
282
282
 set(krunner_xml ${KDEBASE_WORKSPACE_SOURCE_DIR}/krunner/org.kde.krunner.Interface.xml)
305
305
 install(FILES simpleapplet/plasma-applet-simplelauncher.desktop DESTINATION ${SERVICES_INSTALL_DIR})
306
306
Index: kdebase-workspace-4.1.2/libs/kworkspace/kworkspace.h
307
307
===================================================================
308
 
--- kdebase-workspace-4.1.2.orig/libs/kworkspace/kworkspace.h   2008-09-26 01:33:15.000000000 +0200
309
 
+++ kdebase-workspace-4.1.2/libs/kworkspace/kworkspace.h        2008-09-26 01:34:03.000000000 +0200
 
308
--- kdebase-workspace-4.1.2.orig/libs/kworkspace/kworkspace.h   2008-01-05 00:55:29.000000000 +0100
 
309
+++ kdebase-workspace-4.1.2/libs/kworkspace/kworkspace.h        2008-10-11 15:16:18.000000000 +0200
310
310
@@ -52,7 +52,7 @@
311
311
      */
312
312
     ShutdownTypeDefault = -1,
331
331
   /**
332
332
Index: kdebase-workspace-4.1.2/ksmserver/shutdowndlg.h
333
333
===================================================================
334
 
--- kdebase-workspace-4.1.2.orig/ksmserver/shutdowndlg.h        2008-09-26 01:33:15.000000000 +0200
335
 
+++ kdebase-workspace-4.1.2/ksmserver/shutdowndlg.h     2008-09-26 01:34:03.000000000 +0200
 
334
--- kdebase-workspace-4.1.2.orig/ksmserver/shutdowndlg.h        2008-08-28 10:06:54.000000000 +0200
 
335
+++ kdebase-workspace-4.1.2/ksmserver/shutdowndlg.h     2008-10-11 15:16:18.000000000 +0200
336
336
@@ -131,6 +131,7 @@
337
337
     KSMPushButton *m_btnLogout;
338
338
     KSMPushButton *m_btnHalt;
343
343
 private Q_SLOTS:
344
344
Index: kdebase-workspace-4.1.2/ksmserver/shutdowndlg.cpp
345
345
===================================================================
346
 
--- kdebase-workspace-4.1.2.orig/ksmserver/shutdowndlg.cpp      2008-09-26 01:33:15.000000000 +0200
347
 
+++ kdebase-workspace-4.1.2/ksmserver/shutdowndlg.cpp   2008-09-26 01:34:03.000000000 +0200
 
346
--- kdebase-workspace-4.1.2.orig/ksmserver/shutdowndlg.cpp      2008-08-28 10:06:54.000000000 +0200
 
347
+++ kdebase-workspace-4.1.2/ksmserver/shutdowndlg.cpp   2008-10-11 15:16:18.000000000 +0200
348
348
@@ -339,7 +339,7 @@
349
349
     m_btnLogout(0),
350
350
     m_btnHalt(0),
475
475
         m_svg->paint(&p, r, "picture");
476
476
     }
477
477
 }
 
478
Index: kdebase-workspace-4.1.2/libs/kworkspace/kdisplaymanager.cpp
 
479
===================================================================
 
480
--- kdebase-workspace-4.1.2.orig/libs/kworkspace/kdisplaymanager.cpp    2008-10-11 15:16:26.000000000 +0200
 
481
+++ kdebase-workspace-4.1.2/libs/kworkspace/kdisplaymanager.cpp 2008-10-11 15:20:41.000000000 +0200
 
482
@@ -201,7 +201,7 @@
 
483
               KWorkSpace::ShutdownMode shutdownMode, /* NOT Default */
 
484
               const QString &bootOption )
 
485
 {
 
486
-       if (shutdownType == KWorkSpace::ShutdownTypeNone)
 
487
+       if (shutdownType == KWorkSpace::ShutdownTypeNone || shutdownType == KWorkSpace::ShutdownTypeLogout)
 
488
                return;
 
489
 
 
490
        bool cap_ask;