~ubuntu-branches/ubuntu/intrepid/logrotate/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/glob-failure.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2008-10-09 09:03:30 UTC
  • mfrom: (4.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20081009090330-movnqp4egl8wop6m
Tags: 3.7.1-5ubuntu1
* Merge with Debian unstable to get a better fix for LP #256891. Remaining
  Ubuntu changes:
  - debian/control: Drop mailx to Suggests for Ubuntu; it's only used on
    request, and we don't configure an MTA by default.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
# Prevent logrotate from failing completely if one glob in any
2
 
# included file fails. This more or less behaves like an implied
3
 
# "missingok" now, which isn't correctly parsed in the current
4
 
# version.
5
 
# Ubuntu: https://bugs.launchpad.net/bugs/256891
6
 
# Debian: http://bugs.debian.org/277652
7
 
Index: logrotate-3.7.1/config.c
8
 
===================================================================
9
 
--- logrotate-3.7.1.orig/config.c       2008-10-08 13:56:36.000000000 +0200
10
 
+++ logrotate-3.7.1/config.c    2008-10-08 13:56:45.000000000 +0200
11
 
@@ -968,7 +968,7 @@
12
 
 
13
 
                    message(MESS_ERROR, "%s:%d glob failed for %s\n",
14
 
                            configFile, lineNum, argv[argNum]);
15
 
-                   return 1;
16
 
+                   continue;
17
 
                }
18
 
 
19
 
                newlog->files = realloc(newlog->files, sizeof(*newlog->files) *